If x > ; = 0 then if x > ; 0 then write(1) else write(0)else write( - 1) ;Что выведет эта программа при разных значениях x?

Информатика | 5 - 9 классы

If x > ; = 0 then if x > ; 0 then write(1) else write(0)

else write( - 1) ;

Что выведет эта программа при разных значениях x?

1. при x = 15 : 2.

При x = 5 : 3.

При x = 0 : 4.

При x = –5 : 5.

При x = –15 :

Ответить на вопрос
Ответы (2)
17030233 21 нояб. 2023 г., 17:09:18

Ответ :

1 - 1

2 - 1

3 - 1

4 -   ; - 1

5 -   ; - 1

Объяснение :

если x больше или равен 0, то пишется 1.

Ushsa 21 нояб. 2023 г., 17:09:21

Ответ :

1.

При x = 15 : 1

2.

При x = 5 : 1

3.

При x = 0 : 0

4.

При x = –5 : - 1

5.

При x = –15 : - 1

больше 0 : 1

0 : 0

меньше 0 : - 1.

Rostisk 3 нояб. 2023 г., 18:53:28 | 10 - 11 классы

Напишите через запятую что находится в переменных a и b после выполнения алгоритма :A : = 25 ; b : = 5 ;If a> ; 10 then b : = 2 * b else b : = a / 5 ?

Напишите через запятую что находится в переменных a и b после выполнения алгоритма :

A : = 25 ; b : = 5 ;

If a> ; 10 then b : = 2 * b else b : = a / 5 ;

ЛобашоваОлеся 12 нояб. 2023 г., 17:51:38 | студенческий

ДАЮ 50 БАЛЛОВ?

ДАЮ 50 БАЛЛОВ!

СРОЧНО!

Чему равно среднее арифметическое значение элементов массива a[1] и a[2], сформированного следующим образом?

For i : = 1 to 10 do if i mod 2 = 0 then a[i] : = i / 2 else a[i] : = (i + 1) / 2 ; ​.

Кикл 29 нояб. 2023 г., 20:46:02 | студенческий

Определите значение переменной «a» после выполнения фрагмента программы : a : = 10 ; if a < ; 5 then a : = a + 12 else a : = a - 7 ?

Определите значение переменной «a» после выполнения фрагмента программы : a : = 10 ; if a < ; 5 then a : = a + 12 else a : = a - 7 ;

Няшка237 1 дек. 2023 г., 13:12:31 | 5 - 9 классы

Что будет выведено на экран в результате выполнения программы?

Что будет выведено на экран в результате выполнения программы?

X : = 2018 ;

a : = x div 1000 ;

b : = x mod 10 ;

c : = x div 10 mod 10 ;

write(a + b + c) ;

Шроворш 27 окт. 2023 г., 06:20:53 | 5 - 9 классы

! ДАЮ 50 БАЛЛОВ?

! ДАЮ 50 БАЛЛОВ!

2. 1.

Определите, значение какой функции вычисляет написанная программа?

Оформить таблицу вычислений

№ x y

1 - 2

2 0

3 6

program Virajenie ;

uses crt ;

var x, y : real ;

begin clrscr ; write('Значение x = ') ; readln(x) ; if (x< ; 0) then y : = - x else y : = x + 2 ; writeln('При x = ', x : 8 : 2, ' y = ', y : 8 : 2) ; readkey

end.

2. 2.

(БИД) Попробуйте сформулировать, что определяет данная программа.

Оформить таблицу вычислений

№ Первое число Второе число Вывод

1 2 8

2 11 7

3 25 25

program Sravnenie ;

uses crt ;

var a, b : real ;

Begin clrscr ; write('Сравниваемые числа ') ; readln(a, b) ; if (a = b) then writeln('Числа равны') else if (a> ; b) then writeln('Первое число больше') else writeln('Второе число больше') ; readkey

end.

2. 3.

Вычислить значение выражения ………….

Для заданного значения x.

Оформить таблицу вычислений (пользуясь программой, данной ниже, заполните пропуски в условии задачи и таблице)

№ x ?

1 - 3

2 0

3 5

program Virajenie ;

uses crt ;

var x, y : real ;

begin clrscr ; write('Значение x = ') ; readln(x) ; if (x = 0) then writeln('При x = ', x : 8 : 2, ' выражение не определено') else begin y : = x + 1 / x ; writeln('При x = ', x : 8 : 2, ' y = ', y : 8 : 2) end ; readkey

end.

Записать программы

2.

4 Проверить, является ли введенное с клавиатуры целое число четным.

2. 5 Проверить оканчивается ли целое число на 0.

Serega9422 27 нояб. 2023 г., 09:13:34 | 5 - 9 классы

ПОЖАЛУЙСТА СРОЧНО?

ПОЖАЛУЙСТА СРОЧНО!

1. Определите, что будет напечатано в результате работы следующего

фрагмента программы :

var k, s : integer ;

begin

s : = 0 ; k : = 1 ;

repeat

s : = s + k ;

k : = k + 1

until k > ; 11 ;

write(s) ;

end.

2. Определите, что будет напечатано в результате работы следующего

фрагмента программы :

var k, s : integer ;

begin

s : = 0 ;

k : = 0 ;

while k < ; 30 do begin

k : = k + 3 ;

s : = s + k ;

end ;

write(s) ;

end.

Nina5355 8 нояб. 2023 г., 03:15:58 | студенческий

Дана программа на языке Паскаль?

Дана программа на языке Паскаль.

Программа определения весовой категории в зависимости от веса спортсмена.

Если вес спортсмена меньше 62, то «лёгкая категория» иначе «средняя категория».

Заполните пустые окошки.

Program ves ;

const

A1 = 'легкая категория' ;

A2 = 'средняя категория' ;

var

f : integer ;

begin

write('введите вес спортсмена = ') ;

readln(

) ;

if

< ; then writeln(A1) else writeln(A2) ;

readln ;

end.

Гумбат1 26 дек. 2023 г., 05:01:22 | 10 - 11 классы

2)Что будет выведено на экран после выполнения фрагмента программы :begina : = 45 ;if а> ; 10 then n : = а + 15 else n : = a - 11 ;writeln (n) ;end?

2)Что будет выведено на экран после выполнения фрагмента программы :

begin

a : = 45 ;

if а> ; 10 then n : = а + 15 else n : = a - 11 ;

writeln (n) ;

end.

​.

Luna21112002 14 окт. 2023 г., 18:31:48 | 5 - 9 классы

Якого значення набуде змінна х після виконання команд :a = 2b = 1if a> ; b : x = aelse : x = b?

Якого значення набуде змінна х після виконання команд :

a = 2

b = 1

if a> ; b : x = a

else : x = b.

Viteknb 8 дек. 2023 г., 20:01:58 | 5 - 9 классы

1. В каких случаях используется структура if - else?

1. В каких случаях используется структура if - else?

2. Каков синтаксис структуры if - else?

3. В каких случаях применяется структура if - elif - else?

4. Каков синтаксис структуры if - elif - else?

5. Какова функция гора полного разветвления?

6. Какова структура вложенного условного оператора, 7.

Каковы условия применения вложенного условного опе ратора?

​.

Вы перешли к вопросу If x &gt ; = 0 then if x &gt ; 0 then write(1) else write(0)else write( - 1) ;Что выведет эта программа при разных значениях x?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.