Программная реализация ветвящихся алгоритмов?

Информатика | 5 - 9 классы

Программная реализация ветвящихся алгоритмов.

Задание 1.

Создать программу для решения задачи согласно варианту :

Заданы числа a и b.

Если a положительное, то найти их произведение и вывести в формате «Произведение чисел … и … равно …», в остальных случаях найти сумму и вывести в формате «Сумма чисел … и … равна …».

Ответить на вопрос
Ответы (1)
Rotor111 12 апр. 2022 г., 17:54:57

PascalABC.

NET

var

a, b : integer ;

Begin

Readln(a, b) ;

if (a > 0) then

Writeln('Произведение чисел ', a, ' и ', b, ' равно ', a * b)

else

Writeln('Сумма чисел ', a, ' и ', b, ' равна ', a + b) ;

end.

Никто120 28 янв. 2022 г., 14:59:00 | 5 - 9 классы

Составить блок схему и программный код задачи :Вводятся 10 чисел?

Составить блок схему и программный код задачи :

Вводятся 10 чисел.

Вывести на экран сумму положительных и отрицательных чисел и их количество

Пожалуйста решите, очень срочно.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Zaskalov 23 февр. 2022 г., 09:09:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа ролучает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - сумму чисел, кратных 3.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Кир0о0 9 апр. 2022 г., 04:57:04 | 5 - 9 классы

Найти разность, сумму и произведение четырех чисел?

Найти разность, сумму и произведение четырех чисел.

Svtyuga168 10 янв. 2022 г., 18:15:44 | 10 - 11 классы

С помощью цикла while вывести произведение чисел от 1 до 50 С + +?

С помощью цикла while вывести произведение чисел от 1 до 50 С + +.

Tyukov2003 15 мая 2022 г., 06:55:47 | 10 - 11 классы

Если два числа равны , то вывести их сумму, а иначе модуль разности?

Если два числа равны , то вывести их сумму, а иначе модуль разности.

Наташа526 4 февр. 2022 г., 10:53:57 | 5 - 9 классы

Дано N целых чисел?

Дано N целых чисел.

Число называется "красивым", если его можно разделить на 3 без остатка.

Вам нужно выбрать таких K "красивых" чисел, чтобы их сумма была минимальна.

Необходимо вывести эту сумму.

Формат ввода :

N K

A[1] A[2] .

A[N]

Ограничения :

1.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Ryagin 8 мая 2022 г., 13:35:52 | 5 - 9 классы

Помогите, пожалуйста : )1)Вывести на экран натуральные не четные числа от 50 до 40?

Помогите, пожалуйста : )

1)Вывести на экран натуральные не четные числа от 50 до 40.

2)Найти произведение последовательных натуральных чисел от 7 до 12.

На этой странице находится вопрос Программная реализация ветвящихся алгоритмов?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.