Написать программу о нахождении двухзначного числа А?

Информатика | 5 - 9 классы

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Ответить на вопрос
Ответы (1)
2000225880010 15 янв. 2022 г., 01:37:05

Var a, a1, a2 : integer ;

begin

readln(a) ;

a1 : = a div 10 ;

a2 : = a mod 10 ;

writeln("Сумма цифр = ", a1 + a2) ;

writeln("Произведение цифр = ", a1 * a2) ;

writeln("Число наоборот : ", a2 * 10 + a1) ;

end.

Пример :

25

Сумма цифр = 7

Произведение цифр = 10

Число наоборот : 52.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

Kochievaanya 27 янв. 2022 г., 05:25:20 | 1 - 4 классы

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)?

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль).

Mishan9lm 9 мар. 2022 г., 01:54:43 | студенческий

Поменять местами первую и последнюю цифру числа n?

Поменять местами первую и последнюю цифру числа n.

Minikotik200756 8 апр. 2022 г., 06:42:22 | 5 - 9 классы

Паскаль?

Паскаль.

Напишите программу.

Дано трехзначное число, поменять в нем все цифры справа налево, десятки поставить на место сотен, единицы на место десятков, сотни на место единиц.

Dmitretska2005 13 февр. 2022 г., 05:22:02 | 10 - 11 классы

Даю 50 баллов ?

Даю 50 баллов !

Написать программы на языке С + + 1) Данные числа x, y являются координатами точки, лежащей в первой координатной четверти.

2) Даны два трехзначных числа.

Поменять местами 2 - ю цифру первого на 3 - ю цифру второго.

Линка43 18 апр. 2022 г., 06:02:39 | 10 - 11 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, является ли сумма его цифр кратна 3 и 5.

Написать программу на C + + и Pascal.

12364578 12 янв. 2022 г., 08:39:57 | 5 - 9 классы

Нужно на C + +Дано число?

Нужно на C + +

Дано число.

В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным.

В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.

Программа получает на вход одно длинное натуральное число.

Длина числа может достигать 100 цифр.

Программа должна вывести другое натуральное число, удовлетворяющее условиям :

1)Новое число должно отличаться от данного ровно одной цифрой.

2)Новое число должно делиться на 3.

3)Новое число должно быть максимально возможным из всех таких чисел.

Aoverchuk 16 апр. 2022 г., 08:21:23 | 10 - 11 классы

Составить программу?

Составить программу.

Дано число N нужно поменять порядок цифр в этом числе и вывести его.

Число N вводится с клавиатуры.

AliceTzar33 14 мая 2022 г., 17:29:25 | 10 - 11 классы

Помогите пожалуйста) информатика PascalABC1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7?

Помогите пожалуйста) информатика PascalABC

1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7.

2)Составьте программу : с клавиатуры вводятся два натуральных числа x и y.

Вывести на экран все четные числа на отрезке [x, y] и подсчитать сумму этих чисел.

Musta03 27 янв. 2022 г., 01:56:51 | 5 - 9 классы

Найти разность между произведением и суммой цифр трехзначного числа?

Найти разность между произведением и суммой цифр трехзначного числа.

Pascal.

На этой странице сайта размещен вопрос Написать программу о нахождении двухзначного числа А? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.