Дано N целых чисел?

Информатика | 5 - 9 классы

Дано N целых чисел.

Число называется "красивым", если его можно разделить на 3 без остатка.

Вам нужно выбрать таких K "красивых" чисел, чтобы их сумма была минимальна.

Необходимо вывести эту сумму.

Формат ввода :

N K

A[1] A[2] .

A[N]

Ограничения :

1.

Ответить на вопрос
Ответы (1)
Murzer 4 февр. 2022 г., 10:54:03

/ / PascalABC.

NET

var b : array of integer ; m : integer ;

begin / / Ввод данных var n : = ReadInteger('Введите число N всех чисел массива : ') ; var k : = ReadInteger('Введите число К "красивых" чисел : ') ; writeln('Введите все числа в массиве') ; var a : = ReadArrInteger(n) ; / / Резервируем место для слагаемых b : = new integer[k] ; / / Просмотрим все данные числа foreach var i in a do / / Выберем только кратные трем if i mod 3 = 0 then begin / / Если есть свободное место, поместим туда m : = b.

FindIndex(x - > x = 0) ; if m - 1 then b[m] : = i else / / Если свободного места нет, найдем наибольший элемент / / и заменим его begin m : = b.

FindIndex(x - > (x>i) and (x = b.

Max)) ; if m - 1 then b[m] : = i ; end ; end ; / / Выведем сумму write('Сумма элементов - ', b.

Sum)

end.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

DudikGO 5 янв. 2022 г., 01:28:25 | 10 - 11 классы

Дано число А>0?

Дано число А>0.

Необходимо вводить числа, пока сумма введённых чисел по модулю меньше А.

Найти среднее арифметическое введённых чисел.

Составить алгоритм (блок - схему) решения задачи.

Привести тестовый пример.

Rjkmxfr2015 6 янв. 2022 г., 19:49:32 | 5 - 9 классы

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка?

1)Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка.

K вводится с клавиатуры.

2)С клавиатуры вводится целое положительное число.

Определить, сколько в числе цифр.

Katyapanteleev 28 февр. 2022 г., 12:08:46 | студенческий

Даны 3 целых числа, найти сумму кубов этих чисел?

Даны 3 целых числа, найти сумму кубов этих чисел.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Anonimno228 5 янв. 2022 г., 09:14:52 | 5 - 9 классы

Помогите решить?

Помогите решить.

Всё в с + + , для code blocks.

1. Вычислите сумму данных 100 натуральных чисел.

Вводятся 100 чисел, сумму которых необходимо посчитать.

2. Вводится число N, а затем N чисел.

Подсчитайте, сколько среди данных N чисел нулей.

3. Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Вводится число N, а затем N чисел.

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Liliana1110 2 февр. 2022 г., 06:43:54 | 10 - 11 классы

Срочно надо сдать?

Срочно надо сдать!

Написать программу на языке С + +

Дана последовательность n различных целых чисел.

Найти сумму ее членов, расположенных между максимальным и минимальным значениями(в сумму включить и оба этих числа).

Coolgirlgroup 12 апр. 2022 г., 17:54:54 | 5 - 9 классы

Программная реализация ветвящихся алгоритмов?

Программная реализация ветвящихся алгоритмов.

Задание 1.

Создать программу для решения задачи согласно варианту :

Заданы числа a и b.

Если a положительное, то найти их произведение и вывести в формате «Произведение чисел … и … равно …», в остальных случаях найти сумму и вывести в формате «Сумма чисел … и … равна …».

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

Вопрос Дано N целых чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.