Даны натуральные числа m и n?

Информатика | 10 - 11 классы

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

Ответить на вопрос
Ответы (1)
Saina46 11 апр. 2022 г., 05:34:34

Begin s1 : = copy(s, 1, pos(' ', s) - 1) ; {копируем первое слово до пробела} for i : = pos(' ', s) + 1 to length(s) do{смотрим строку дальше} if (copy(s, i, length(s1)) = s1){если набор символов совпадает с этим словом} and(s[i - 1] = ' '){и перед ним пробел} and((s[i + length(s1)] = ' '){и за ним пробел} or(i + length(s1) - 1 = length(s))) then{или это последнее слово} begin k : = 1 ; {фиксируем совпадение} s2 : = s1 ; {запоминаем слово} write('Одинаковые слова ', s2) ; {выводим на экран} readln ; exit ; {выходим из программы, нужно только 1 пару} end ; delete(s, 1, pos(' ', s)) ; {удаляем первое слово, следующее первое}

end ;

if k = 0 then write('Нет двух одинаковых слов') ;

readln

end.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Vlad211003 28 янв. 2022 г., 00:02:38 | 5 - 9 классы

1. Дано натуральное число?

1. Дано натуральное число.

Определить :

а) является ли оно чётным

б) оканчивается ли оно цифрой 7.

Дано двухзначное число.

Определить :

а) кратна ли трём его сумма цифр

б) кратна ли сумма его чисел числу а.

ПОМОГИТЕ РЕБЯТАААА!

ООЙЙ КАК СРОЧНО НАДОО.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

ЛанаЧ200312 8 февр. 2022 г., 01:42:52 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры

б) сумма квадратов чисел в диапазоне от 1 до n

в) количество натуральных чисел не превышающих 50 и кратных 3.

PolinaKim900 7 янв. 2022 г., 21:19:18 | 5 - 9 классы

Дано натуральное число 10?

Дано натуральное число 10.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Катя45879 4 янв. 2022 г., 23:19:11 | 5 - 9 классы

Задача 9Дано натуральное четырехзначное число?

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

Assertivee 1 февр. 2022 г., 23:09:51 | 5 - 9 классы

Дано натуральное число n (n < 9999)?

Дано натуральное число n (n < 9999).

Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр).

Например, в числе 3678 все цифры различны, в числе 0023 — нет.

На странице вопроса Даны натуральные числа m и n? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.