Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Информатика | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Ответить на вопрос
Ответы (1)
Olkhovskiyem 28 мар. 2022 г., 08:53:07

Var n, s : integer ;

begin

readln(n) ;

s : = 0 ;

while n>0 do

begin

s : = s + n mod 10 ;

n : = n div 10 ;

end ;

writeln(s div 10 + s mod 10) ;

end.

Пример :

4093

7.

Vlad211003 28 янв. 2022 г., 00:02:38 | 5 - 9 классы

1. Дано натуральное число?

1. Дано натуральное число.

Определить :

а) является ли оно чётным

б) оканчивается ли оно цифрой 7.

Дано двухзначное число.

Определить :

а) кратна ли трём его сумма цифр

б) кратна ли сумма его чисел числу а.

ПОМОГИТЕ РЕБЯТАААА!

ООЙЙ КАК СРОЧНО НАДОО.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Kotenok2005ann 15 мар. 2022 г., 14:21:44 | 5 - 9 классы

Прошу решите на PascalABC или PhytonДано натуральное число?

Прошу решите на PascalABC или Phyton

Дано натуральное число.

Требуется разделить запятыми тройки его цифр(считая справа).

Входные данные содержат натуральное число, не превосходящее 10 в 100

Выходные данные.

То же число, разделяя тройки цифр запятыми.

Примеры :

Входные Выходные

1000 1, 000

12345 12, 345.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Диля45 10 мая 2022 г., 15:22:41 | 5 - 9 классы

Решите пожалуйста задачу на питоне, срочно нужно?

Решите пожалуйста задачу на питоне, срочно нужно!

Желательно с пояснениями!

Билет считается счастливым, если в его n - значном номере сумма первых [n / 2] цифр равна сумме [n / 2] последних цифр (при нечетном n центральная цифра в “проверке на счастье” не участвует и может быть любой).

Подсчитайте число счастливых билетов с различными n - значными номерами (ведущие нули в номерах возможны, но номера, состоящего из одних нулей, не существует).

Входные данные

На вход программе подается натуральное число n < 16.

Выходные данные

Выведите количество n - значных счастливых билетов.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Катя45879 4 янв. 2022 г., 23:19:11 | 5 - 9 классы

Задача 9Дано натуральное четырехзначное число?

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Coollyudmila202 11 апр. 2022 г., 05:34:32 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

Вопрос Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.