Дано натуральное число 10?

Информатика | 5 - 9 классы

Дано натуральное число 10.

Ответить на вопрос
Ответы (1)
Dashcazack2016 7 янв. 2022 г., 21:19:25

Program PascalGuru ;

type cisla = 1.

1000000 ;

function summa(chislo : integer) : integer ;

var s : integer ;

begin

s : = 0 ;

while (chislo > 0) do

begin

s : = s + (chislo mod 10) ;

chislo : = chislo div 10

end ;

summa : = s

end ;

{ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - }

var i, n : cisla ;

rezult : integer ;

begin

write('n = ') ; readln(n) ;

rezult : = 0 ;

for i : = 1 to 1000000 do

if summa(i) = n then begin rezult : = i ; break ; end ;

writeln(rezult) ;

readln ;

end.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Glavnagolova 22 февр. 2022 г., 01:40:49 | студенческий

Даны натуральное число N и действительное число x?

Даны натуральное число N и действительное число x.

Вычислить S = sinx + sinsinx + .

+ {sinsin.

Sinx} n раз

C#.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

NellyLove 30 янв. 2022 г., 03:21:36 | 5 - 9 классы

Дано натуральное число n найдите сумму его чисел и произведение?

Дано натуральное число n найдите сумму его чисел и произведение.

В PascalABC, и через команду while.

Катя45879 4 янв. 2022 г., 23:19:11 | 5 - 9 классы

Задача 9Дано натуральное четырехзначное число?

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Coollyudmila202 11 апр. 2022 г., 05:34:32 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

Alis6 9 мар. 2022 г., 18:44:37 | 5 - 9 классы

Даны натуральные числа n, a1 ?

Даны натуральные числа n, a1 .

An определить количество членов последовательности, являющихся нечетными числами.

На этой странице вы найдете ответ на вопрос Дано натуральное число 10?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.