Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

Ответить на вопрос
Ответы (1)
Фархад14323 24 янв. 2022 г., 17:01:27

Вот два варианта решения :

1)В первом варианте программа выдает неверный ответ, если в числе есть хотя бы один ноль.

Var

a, n, i, min, tmp, m : integer ;

begin

m : = 1 ;

read(a) ;

tmp : = a ;

n : = 0 ;

min : = 10 ;

while tmp > 0 do begin n : = n + 1 ; if(tmp mod 10 < min) then min : = tmp mod 10 ; tmp : = tmp div 10 ;

end ;

for i : = 1 to n do m : = m * 10 ;

a : = a + (min * m) ;

a : = a * 10 ;

a : = a + min ;

write(a) ;

end.

2)Второй вариант с использованием строки :

var

s : string ;

i, min : integer ;

begin

readln(s) ;

min : = 10 ;

for i : = 1 to length(s) do if(strtoint(s[i]) < min) then min : = strtoint(s[i]) ;

s : = s + inttostr(min) ;

s : = inttostr(min) + s ;

writeln(s) ;

end.

Zenya1300danil 11 янв. 2022 г., 02:13:25 | 5 - 9 классы

Даны два числа?

Даны два числа.

Найти минимальное из них.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Tatev02 20 янв. 2022 г., 11:05:43 | 5 - 9 классы

Дано число его удвоить и утроить составить программу в паскаль?

Дано число его удвоить и утроить составить программу в паскаль.

Kochievaanya 27 янв. 2022 г., 05:25:20 | 1 - 4 классы

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)?

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль).

Dasha29f 10 февр. 2022 г., 20:51:31 | 5 - 9 классы

Дано трехзначное число Х, вводимое с клавиатуры?

Дано трехзначное число Х, вводимое с клавиатуры.

Первую цифру этого числа перенесли в конец.

Вывести на экран полученное число.

( работать в паскале).

Yunalichka 14 янв. 2022 г., 00:28:40 | 5 - 9 классы

Напишите программу на языке Паскаль?

Напишите программу на языке Паскаль!

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем числе.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

Matchitovak 6 янв. 2022 г., 15:16:17 | 5 - 9 классы

Даны три числа найти максимальное, среднее, минимальное?

Даны три числа найти максимальное, среднее, минимальное.

На этой странице сайта размещен вопрос Дано натуральное число? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.