Задача 9Дано натуральное четырехзначное число?

Информатика | 5 - 9 классы

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Ответить на вопрос
Ответы (1)
Umangulovasaid 4 янв. 2022 г., 23:19:15

Народ последнюю задачку проверьте пожалуйста!

Опять не могу найти ошибку

УСЛОВИЕ :

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

РЕШЕНИЕ :

PascalВыделить код1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

var n, a, b, c, d : integer ;

f, g : text ;

begin

assign(f, 'input.

Txt') ;

assign(g, 'output.

Txt') ;

reset(f) ;

rewrite(g) ;

readln(f, n) ;

a : = n div 1000 ;

b : = n div 100 mod 10 ;

c : = (n mod 100) div 10 ;

d : = n mod 10 ;

if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) and (d mod 2 = 0) and (n0) then writeln(g, ' - 1') else

if (a.

Djalilchik 3 янв. 2022 г., 09:42:27 | 5 - 9 классы

ИВТ 99 БАЛЛОВ?

ИВТ 99 БАЛЛОВ!

Напишите программу в паскале

Даны два БоЛьШуЩиХ ЧиСЛа.

Проверьте, делится ли их произведение на девять.

Формат файла входных данных :

В двух строках входного файла даны два целых неотрицательных числа, по одному в строке.

Запись каждого из них состоит из не более чем 106 цифр.

Формат файла выходных данных :

В единственной строке выходного файла выведите "YES", если произведение данных чисел делится на девять, и "NO" в противном случае (без кавычек).

Пример :

72

840

YES

3

5

NO

Ограничение по времени : 3 сек

Ограничение по памяти : 256 Мб

Обычная программа по типу перемножить числа и проверить, кратно ли произведение 9 НЕ ПОДХОДИТ

Пожалуйста, учитывайте ограничения по времени и памяти.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Тёма210 14 февр. 2022 г., 03:09:53 | 5 - 9 классы

ДЛЯ ПИТОНАНапишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min?

ДЛЯ ПИТОНА

Напишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min.

Считайте четыре целых числа и выведите их минимум.

Входные данные

Вводятся четыре целых числа.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

4

5

6

7

выходные данные

4.

Kotenok2005ann 15 мар. 2022 г., 14:21:44 | 5 - 9 классы

Прошу решите на PascalABC или PhytonДано натуральное число?

Прошу решите на PascalABC или Phyton

Дано натуральное число.

Требуется разделить запятыми тройки его цифр(считая справа).

Входные данные содержат натуральное число, не превосходящее 10 в 100

Выходные данные.

То же число, разделяя тройки цифр запятыми.

Примеры :

Входные Выходные

1000 1, 000

12345 12, 345.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Bulambaev03 4 мар. 2022 г., 20:18:35 | 10 - 11 классы

На питонеВыведите все четные элементы списка?

На питоне

Выведите все четные элементы списка.

Входные данные

Вводится список чисел.

Все числа списка находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1 2 2 3 3 3 4

выходные данные

2 2 4.

На этой странице находится вопрос Задача 9Дано натуральное четырехзначное число?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.