Дано трехзначное число?

Информатика | 5 - 9 классы

Дано трехзначное число.

Составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры

б) сумма квадратов чисел в диапазоне от 1 до n

в) количество натуральных чисел не превышающих 50 и кратных 3.

Ответить на вопрос
Ответы (1)
Dasha29f 8 февр. 2022 г., 01:42:53

A)

Program hhh54 ;

var x : longint ;

begin read (x) ; if ((x div 100) + (x mod 10)) mod 5 = 0 then write ('КРАТНА') else write ('НЕ КРАТНА') ;

end.

Б)

Program hhh54 ;

var s, n, i : longint ;

begin s : = 0 ; read (n) ; for i : = 1 to n do s : = s + sqr(i) ; write (s) ;

end.

В)

Program hhh54 ;

var k, n, i : longint ;

begin k : = 0 ; for i : = 1 to 50 do if i mod 3 = 0 then k : = k + 1 ; write (k) ;

end.

ТетеринКирилл 13 янв. 2022 г., 07:39:59 | 5 - 9 классы

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6?

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность через repeat until.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

НеЕдинорог11 9 янв. 2022 г., 10:49:24 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3?

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 1000.

Введённые числа не превыша ют 30 000.

Программа должна вывести одно число — минимальное число, кратное 3.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Zaskalov 23 февр. 2022 г., 09:09:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа ролучает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - сумму чисел, кратных 3.

Lerynya1 14 апр. 2022 г., 21:25:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи - вается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число : сумму всех чисел, кратных 3 и оканчивающихся на 8.

Пример работы программы : Входные данные Выходные данные 23 48 12 18 34 0 66.

Ozboy 2 мая 2022 г., 15:21:24 | 10 - 11 классы

Найти сумму квадратов первых n натуральных чисел?

Найти сумму квадратов первых n натуральных чисел.

Паскааль.

Anbushinova99 11 апр. 2022 г., 15:33:45 | 5 - 9 классы

Программа получает на вход количество чисел в последовательности, а затем сами числа?

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000.

Введённые числа по модулью не превышают 30 000.

Программа должна вывести одно число : сумму чисел, кратных 7 и оканчивающихся на 4.

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

На этой странице находится ответ на вопрос Дано трехзначное число?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.