Дано натуральное число n найдите сумму его чисел и произведение?

Информатика | 5 - 9 классы

Дано натуральное число n найдите сумму его чисел и произведение.

В PascalABC, и через команду while.

Ответить на вопрос
Ответы (1)
Marko228 30 янв. 2022 г., 03:21:41

Program asdw ;

Uses crt ;

Var x, s, s1 : integer ;

begin

read (x) ;

s1 : = 1 ;

s : = 1 ;

while x>0 do

begin

s1 : = s1 * x mod 10 ;

s : = s + x mod 10 ;

x : = x div 10 ;

end ;

writeln (s) ;

writeln (s1) ;

end.

Vlad211003 28 янв. 2022 г., 00:02:38 | 5 - 9 классы

1. Дано натуральное число?

1. Дано натуральное число.

Определить :

а) является ли оно чётным

б) оканчивается ли оно цифрой 7.

Дано двухзначное число.

Определить :

а) кратна ли трём его сумма цифр

б) кратна ли сумма его чисел числу а.

ПОМОГИТЕ РЕБЯТАААА!

ООЙЙ КАК СРОЧНО НАДОО.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Kotenok2005ann 15 мар. 2022 г., 14:21:44 | 5 - 9 классы

Прошу решите на PascalABC или PhytonДано натуральное число?

Прошу решите на PascalABC или Phyton

Дано натуральное число.

Требуется разделить запятыми тройки его цифр(считая справа).

Входные данные содержат натуральное число, не превосходящее 10 в 100

Выходные данные.

То же число, разделяя тройки цифр запятыми.

Примеры :

Входные Выходные

1000 1, 000

12345 12, 345.

Tasha7777 19 февр. 2022 г., 07:43:25 | 5 - 9 классы

Решить две задачи в паскаль1?

Решить две задачи в паскаль

1.

Даны действительные числа x и y, не равные друг другу.

Меньшее из этих двух чисел заменить половиной их суммы, а большее - их удвоенным произведение.

2. Дано 2 различных числа a и b, если их сумма меньше 65 то большее число заменить произведением чисел, в противном удвоенной суммой а другое число без изменений

Подсказка задача решается через команду IF.

Also7 9 мая 2022 г., 16:40:17 | 5 - 9 классы

Даны три числа?

Даны три числа.

Вычислите сумму 1и2 чисел и разность между суммой и 3 числом.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Coollyudmila202 11 апр. 2022 г., 05:34:32 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

AliceTzar33 14 мая 2022 г., 17:29:25 | 10 - 11 классы

Помогите пожалуйста) информатика PascalABC1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7?

Помогите пожалуйста) информатика PascalABC

1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7.

2)Составьте программу : с клавиатуры вводятся два натуральных числа x и y.

Вывести на экран все четные числа на отрезке [x, y] и подсчитать сумму этих чисел.

Незнайка124 25 мар. 2022 г., 22:06:53 | 5 - 9 классы

Составьте программу, которая вычисляет произведение натуральных чисел от 5 до 10 и выводит на экран результат (ИСПОЛЬЗОВАТЬ ТОЛЬКО ЦИКЛ while)?

Составьте программу, которая вычисляет произведение натуральных чисел от 5 до 10 и выводит на экран результат (ИСПОЛЬЗОВАТЬ ТОЛЬКО ЦИКЛ while).

На этой странице сайта вы найдете ответы на вопрос Дано натуральное число n найдите сумму его чисел и произведение?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.