На вход программы поступает последовательность из N натуральных чисел?

Информатика | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

Ответить на вопрос
Ответы (1)
Maximovsyannik 28 янв. 2022 г., 13:28:23

Var a, n, i, sum, c, min : integer ;

begin sum : = 0 ; c : = 0 ; min : = 10001 ; read(n) ; for i : = 1 to n do

begin read(a) ; sum : = sum + a ; c : = c + 1 ; if(a < min) and (a mod 4 0) then min : = a ; end ; if(sum mod 4 = 0) and (min 10001) then begin sum : = sum - min ; c : = c - 1 ; end ; if(sum mod 4 = 0) then begin write(0) ; exit ; end ; writeln(c, ' ', sum) ;

end.

Zhuzhkova89 1 мар. 2022 г., 02:13:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 1?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 1.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 1.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число – максимальное число, оканчивающееся на 1.

Пример работы программы : Входные данные : 3 11 21 31 Выходные данные : 31.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Zaskalov 23 февр. 2022 г., 09:09:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа ролучает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - сумму чисел, кратных 3.

Lerynya1 14 апр. 2022 г., 21:25:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи - вается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число : сумму всех чисел, кратных 3 и оканчивающихся на 8.

Пример работы программы : Входные данные Выходные данные 23 48 12 18 34 0 66.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Ryabikina81 18 янв. 2022 г., 02:11:11 | 5 - 9 классы

Программа на c + +Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] ?

Программа на c + +

Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b .

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести квадраты чисел в диапазоне [ a , b ] и показать способ вычисления.

Например, если ввести 4 и 5, программа должна вывести

4 * 4 = 16

5 * 5 = 25.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Anbushinova99 11 апр. 2022 г., 15:33:45 | 5 - 9 классы

Программа получает на вход количество чисел в последовательности, а затем сами числа?

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000.

Введённые числа по модулью не превышают 30 000.

Программа должна вывести одно число : сумму чисел, кратных 7 и оканчивающихся на 4.

На этой странице находится ответ на вопрос На вход программы поступает последовательность из N натуральных чисел?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.