Решить две задачи в паскаль1?

Информатика | 5 - 9 классы

Решить две задачи в паскаль

1.

Даны действительные числа x и y, не равные друг другу.

Меньшее из этих двух чисел заменить половиной их суммы, а большее - их удвоенным произведение.

2. Дано 2 различных числа a и b, если их сумма меньше 65 то большее число заменить произведением чисел, в противном удвоенной суммой а другое число без изменений

Подсказка задача решается через команду IF.

Ответить на вопрос
Ответы (1)
1Qwik1 19 февр. 2022 г., 07:43:27

1. program XandY

var x, y : real ;

begin

readln (x, y) ;

if (x > y) then

begin

y : = (a + b) div 2

x : = 2 * x * y ;

writeln ('x = ', x, ', y = ', y)

end.

2. program AandB

var a, b ;

begin

readln (a, b) ;

if ((a + b) < 65) then

if (a > b) then a : = a * b else b : = a * b

else if (a > b) then a : = 2 * (a + b) else b : = 2 * (a + b)

end.

DudikGO 5 янв. 2022 г., 01:28:25 | 10 - 11 классы

Дано число А>0?

Дано число А>0.

Необходимо вводить числа, пока сумма введённых чисел по модулю меньше А.

Найти среднее арифметическое введённых чисел.

Составить алгоритм (блок - схему) решения задачи.

Привести тестовый пример.

Katyapanteleev 28 февр. 2022 г., 12:08:46 | студенческий

Даны 3 целых числа, найти сумму кубов этих чисел?

Даны 3 целых числа, найти сумму кубов этих чисел.

Littlesong2 17 февр. 2022 г., 15:11:12 | 10 - 11 классы

В паскале?

В паскале.

Изменить программу так, что бы она находила : 1)сумму четырёх чисел

2)произведения чисел

3)квадрат каждого числа.

КсенияРома 15 мар. 2022 г., 19:30:20 | 10 - 11 классы

Даны действительные числа A, B, C, D?

Даны действительные числа A, B, C, D.

Если AD, то числа оставить без изменения ; в противном случае все числа заменяются их квадратами.

Паскаль, пжл!

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Also7 9 мая 2022 г., 16:40:17 | 5 - 9 классы

Даны три числа?

Даны три числа.

Вычислите сумму 1и2 чисел и разность между суммой и 3 числом.

NellyLove 30 янв. 2022 г., 03:21:36 | 5 - 9 классы

Дано натуральное число n найдите сумму его чисел и произведение?

Дано натуральное число n найдите сумму его чисел и произведение.

В PascalABC, и через команду while.

Малинка753 7 февр. 2022 г., 09:43:21 | студенческий

Написать прогу на C# с помощью функции ifДаны два числа?

Написать прогу на C# с помощью функции if

Даны два числа.

Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением.

Shonokakeanfis0ce 2 февр. 2022 г., 19:16:39 | 1 - 4 классы

Язык паскаль с клав ввод 2 числа x и y не равные друг другу?

Язык паскаль с клав ввод 2 числа x и y не равные друг другу.

Меньший из этих двух числ заменить их пол суммы а большие их удвоен произвед.

Kabidenov 10 апр. 2022 г., 19:05:57 | 5 - 9 классы

Как сделать сумму чисел меньше 10, причем числа находятся в массиве в интервале 1?

Как сделать сумму чисел меньше 10, причем числа находятся в массиве в интервале 1.

1000

(Паскаль).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Решить две задачи в паскаль1?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.