Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s?

Информатика | студенческий

Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s.

Составить линейную программу в паскале.

Ответить на вопрос
Ответы (1)
Мандаринка2089 17 февр. 2022 г., 09:25:16

Var a, b, r, s, c : integer ;

begin

readln(a, b) ;

readln(r, s) ;

c : = a mod b ;

writeln((c = r)or(c = s)) ;

end.

Пример :

18 4

2 5

True.

Tatev02 20 янв. 2022 г., 11:05:43 | 5 - 9 классы

Дано число его удвоить и утроить составить программу в паскаль?

Дано число его удвоить и утроить составить программу в паскаль.

Aliona10 21 янв. 2022 г., 19:20:14 | 5 - 9 классы

Вводятся целые числа A и B?

Вводятся целые числа A и B.

Выведите среднее арифметическое всех неотрицательных чисел от A до B

Нужно составить программу в паскале.

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

Kochievaanya 27 янв. 2022 г., 05:25:20 | 1 - 4 классы

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)?

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль).

Рапапапа 23 янв. 2022 г., 21:41:42 | 10 - 11 классы

Написать программу в с + + , определяющую, какое число чаще других встречается в последовательности целых случайных чисел?

Написать программу в с + + , определяющую, какое число чаще других встречается в последовательности целых случайных чисел.

Для генерации чисел использовать линейный конгруэнтный метод.

TeriLis 13 апр. 2022 г., 04:02:47 | 5 - 9 классы

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран?

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран.

EkSpErTiK 4 февр. 2022 г., 23:06:54 | 5 - 9 классы

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке?

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.

Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0).

Числа, следующие за числом 0, считывать не нужно.

Решить на питоне.

Ponqi 22 апр. 2022 г., 01:13:33 | 5 - 9 классы

Составьте на Паскале программу, которая определит, является ли целое число N четным двузначным числом?

Составьте на Паскале программу, которая определит, является ли целое число N четным двузначным числом.

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Vladuk9666 4 июн. 2022 г., 18:31:49 | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

На этой странице находится ответ на вопрос Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s?, из категории Информатика, соответствующий программе для студенческий. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.