Вводятся целые числа A и B?

Информатика | 5 - 9 классы

Вводятся целые числа A и B.

Выведите среднее арифметическое всех неотрицательных чисел от A до B

Нужно составить программу в паскале.

Ответить на вопрос
Ответы (1)
Tim270120031 21 янв. 2022 г., 19:20:18

1 способ

var

a, b : integer ;

begin

write('Введите a : ') ;

readln(a) ;

write('Введите b : ') ;

readln(b) ;

var x : = Range(a, b) ;

writeln('Последовательность : ') ;

x.

Println ;

writeln('Ср.

Ариф.

Неотриц чисел : ') ;

writeln(x.

Where(x - > x > = 0).

Average) ;

end.

2 способ

var a, b, i, s : integer ; k : real ;

begin

write('Введите a : ') ;

readln(a) ;

write('Введите b : ') ;

readln(b) ;

writeln('Последовательность : ') ;

for i : = a to b dowrite(i, ' ') ;

writeln() ;

s : = 0 ;

for i : = a to b do

if i> = 0 then begin

s : = s + i ;

k : = k + 1 ;

end ;

writeln('Ср.

Ариф.

Неотриц чисел : ') ;

write(s / k) ;

end.

Yunalichka 14 янв. 2022 г., 00:28:40 | 5 - 9 классы

Напишите программу на языке Паскаль?

Напишите программу на языке Паскаль!

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем числе.

WinnerGDWot027 11 февр. 2022 г., 10:49:04 | 5 - 9 классы

На экран вводится два пятизначных числа?

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем из чисел.

Zubkol 3 февр. 2022 г., 01:01:19 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Программы в Паскале.

1)Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введенных с клавиатуры.

Примеры : 4 + 5 + 7 = 16 ; 4 * 5 * 7 = 140 ; (4 + 5 + 7) / 3 = 5.

333. 2)Напишите программу, которая вводит радиус и вычисляет его площадь и длину окружности.

Примеры : радиус 5 ; площ.

И длин.

Окр. 78.

540, 31.

416

3)Напишите программу, которая вводит два целых числа, а и b(а.

Kpzaorenburg 10 февр. 2022 г., 06:13:44 | 5 - 9 классы

Помогите с Паскалем?

Помогите с Паскалем!

)

1) Рассчитать площадь круга.

Радиус вводится во время программы

2) Рассчитать площадь кольца.

Данные вводятся во время выполнения программы.

3) С клавиатурой вводиться 5 чисел.

Найти их сумму, произведение и среднее арифметическое.

Renat7 17 февр. 2022 г., 09:25:15 | студенческий

Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s?

Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s.

Составить линейную программу в паскале.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

MultyPulty 8 февр. 2022 г., 14:27:57 | 5 - 9 классы

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных)?

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных).

Вычислить среднее арифметическое нечетных и отрицательных из них.

Нужна программа для паскаля.

Vitaymba200 9 мар. 2022 г., 01:48:45 | студенческий

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательностиНа паскале ?

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательности

На паскале (через for to do).

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

На странице вопроса Вводятся целые числа A и B? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.