Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Информатика | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Ответить на вопрос
Ответы (1)
Erik1207 4 июн. 2022 г., 18:31:50

Var a, b, a1, b1 : word ;

begin

writeln('Введите два натуральных числа') ;

readln(a, b) ;

a1 : = a div b ;

a1 : = ((a1 + 2) div (a1 + 1)) mod 2 ;

b1 : = (a1 + 1) mod 2 ; writeln('Число ', a * a1 + b * b1, ' не меньше ', a * b1 + b * a1) ;

end.

Ilyasqwep 13 янв. 2022 г., 01:12:23 | 5 - 9 классы

Программа для перевода сантиметров в метры с помощью div и mod (Паскаль)?

Программа для перевода сантиметров в метры с помощью div и mod (Паскаль).

Заранее спасибо!

Bonushajon 2 янв. 2022 г., 09:23:59 | 5 - 9 классы

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел?

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел.

Nastena199830 3 янв. 2022 г., 05:14:32 | 5 - 9 классы

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел C + +?

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел C + +.

TeriLis 13 апр. 2022 г., 04:02:47 | 5 - 9 классы

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран?

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран.

Xristenko 21 апр. 2022 г., 09:41:55 | 5 - 9 классы

Напишите программу, которая считывает с клавиатуры последовательно ири строки : название фильма, название кинотеатра и время, после чего выводит на экран "Билет на "[название фильма]" в "[название кин?

Напишите программу, которая считывает с клавиатуры последовательно ири строки : название фильма, название кинотеатра и время, после чего выводит на экран "Билет на "[название фильма]" в "[название кинотеатра]" на [время] забронирован.

Помогите , пожалуйста.

Как вывести значение переменной в кавычках?

Renat7 17 февр. 2022 г., 09:25:15 | студенческий

Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s?

Определить, верно ли, что при делении неотрицательного числа А на положительное целое число В получается остаток равный одному из двух заданных чисел r или s.

Составить линейную программу в паскале.

Mothova 28 мар. 2022 г., 11:23:10 | 5 - 9 классы

Напишите программу, которая считывает сообщение, затем номер?

Напишите программу, которая считывает сообщение, затем номер.

После этого программа выводит букву из сообщения с таким номером, причём считается, что номера букв отсчитываются с единицы.

Если введённое число не является правильным номером буквы, вывести «ОШИБКА».

На языке Phyton.

Dinam03777 29 мая 2022 г., 06:58:52 | 5 - 9 классы

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших?

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших.

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

На этой странице вы найдете ответ на вопрос Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.