Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке?

Информатика | 5 - 9 классы

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке.

Ответить на вопрос
Ответы (2)
Fevzifevziev 20 сент. 2020 г., 02:15:24

Var a : array[1.

1000] of integer ;

n, i : integer ;

beginread(n) ;

for i : = 1 to n do

read(a[i]) ;

for i : = n downto 1 do

if i mod 2< ; > ; 0 then

write (a[i] : 5) ;

End.

Halynavasenova 20 сент. 2020 г., 02:15:30

/ / PascalABC.

NET (версия 3.

1, сборка 1210 от 29.

03. 2016)

var a : array of integer ; i, n : integer ;

begin / / Заполняем массив сл.

Числами и выводим / / массив нумеруется с 0

write('Число элементов массива ') ; readln(n) ;

setlength(a, n) ;

for i : = 0 to n - 1 do begin a[i] : = random(21) - 10 ; write(a[i] : 4) ;

end ;

writeln ; / / Вывод элементов с неч.

Номерами в обратном порядке

for i : = n - 1 downto 0 do if i mod 2 < ; > ; 0 then write(a[i] : 4) ;

end.

Тестовое решение :

Число элементов массива 8 - 2 2 - 6 - 5 1 3 - 7 - 10 - 10 3 - 5 2.

ОлькаЕС 6 апр. 2020 г., 14:56:56 | 5 - 9 классы

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов?

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Спасибо : ).

Sumluk 27 июл. 2020 г., 11:23:20 | 10 - 11 классы

Пожалуйста, помогите составить программу правильно?

Пожалуйста, помогите составить программу правильно!

Вот условие : Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке.

Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

На Паскале.

Kashetay 27 февр. 2020 г., 07:31:35 | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Daryachernykh 5 окт. 2020 г., 23:07:05 | 10 - 11 классы

Вывести на экран дисплея порядковые номера нечетных элементов массива целых чисел?

Вывести на экран дисплея порядковые номера нечетных элементов массива целых чисел.

Школа88 9 февр. 2020 г., 18:10:25 | 5 - 9 классы

Написать программу?

Написать программу.

Которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.

Tu110380 2 апр. 2020 г., 21:14:42 | 10 - 11 классы

50 Баллов?

50 Баллов.

Пожалуйста.

В Паскаль.

Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Gulnarochka1 30 дек. 2020 г., 10:50:10 | 5 - 9 классы

Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K?

Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

Galievadianka 5 янв. 2020 г., 02:03:12 | 5 - 9 классы

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы?

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Спасибо.

Sunstar 25 июн. 2020 г., 03:44:52 | 5 - 9 классы

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран?

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.

Перед вами страница с вопросом Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.