Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы?

Информатика | 5 - 9 классы

Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы.

Протестировать алгоритм для следующих массивов : а) 3 5 - 2 3 - 2 0 - 6 - 8 1 б) - 1 - 2 - 3 - 4 0 - 1 2 3 Написать программу на языке Паскаль.

Ответить на вопрос
Ответы (1)
Продюсер 11 сент. 2020 г., 05:36:55

Const nn = 50 ;

var a, b, nb : array[1.

Nn] of integer ; i, n, j : integer ;

begin Write('Введите количество элементов в массиве (n< ; 51) : ') ; Read(n) ; Writeln('Вводите элементы массива') ; j : = 0 ; for i : = 1 to n do begin Read(a[i]) ; if a[i]< ; 0 then begin Inc(j) ; b[j] : = a[i] ; nb[j] : = i end end ; if j> ; 0 then begin Write('Отрицательные элементы : ') ; for i : = 1 to j do Write(b[i], ' ') ; Writeln ; Write('Индексы отрицательных элементов в массиве : ') ; for i : = 1 to j do Write(nb[i] : 3) ; Writeln end

end.

Результаты тестирования :

Введите количество элементов в массиве (n< ; 51) : 9

Вводите элементы массива

3 5 - 2 3 - 2 0 - 6 - 8 1

Отрицательные элементы : - 2 - 2 - 6 - 8

Индексы отрицательных элементов в массиве : 3 5 7 8

Введите количество элементов в массиве (n< ; 51) : 8

Вводите элементы массива - 1 - 2 - 3 - 4 0 - 1 2 3

Отрицательные элементы : - 1 - 2 - 3 - 4 - 1

Индексы отрицательных элементов в массиве : 1 2 3 4 6.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

ОлькаЕС 6 апр. 2020 г., 14:56:56 | 5 - 9 классы

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов?

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Спасибо : ).

Sumluk 27 июл. 2020 г., 11:23:20 | 10 - 11 классы

Пожалуйста, помогите составить программу правильно?

Пожалуйста, помогите составить программу правильно!

Вот условие : Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке.

Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

На Паскале.

Aminasuvorova 26 сент. 2020 г., 19:31:59 | 10 - 11 классы

Пожалуста?

Пожалуста!

ОЧ срочно!

Написать программу на паскале, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы.

Протестировать программу для следующих массивов : а) 3 5 - 2 0 - 6 - 8 1 б) - 1 - 2 - 3 0 - 1 2 3 массивы должны вводися вручную а не рандомно.

Школа88 9 февр. 2020 г., 18:10:25 | 5 - 9 классы

Написать программу?

Написать программу.

Которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.

Витасе34 17 мар. 2020 г., 06:37:28 | 5 - 9 классы

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ : 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного типа?

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ : 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного типа.

Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип.

Ввод организуйе с исползованием цикла "ДЛЯ".

3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа.

Каждый элемнт вычислите по формуле : значение элемента равно квадрату его индекса.

Tu110380 2 апр. 2020 г., 21:14:42 | 10 - 11 классы

50 Баллов?

50 Баллов.

Пожалуйста.

В Паскаль.

Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Galievadianka 5 янв. 2020 г., 02:03:12 | 5 - 9 классы

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы?

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Спасибо.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

Мерипопенс 20 сент. 2020 г., 02:15:23 | 5 - 9 классы

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке?

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке.

Вы зашли на страницу вопроса Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.