C + +Дан массивaaизnnэлементов?

Информатика | 5 - 9 классы

C + +

Дан массив

a

a

из

n

n

элементов.

Перенесите последний элемент массива на место

k

k - го элемента.

При этом

k

k - й,

(k + 1)

(k + 1) - й, .

, предпоследний элементы сдвинуть вправо на 1 позицию.

Формат входных данных

С клавиатуры вводится натуральное число

n

n

(

n≤100

n≤100

)— размер массива.

Во второй строке вводятся

n

n

элементов массива через пробел.

Все элементы целые и не превосходят по модулю

100

100

.

В последней строке вводится одно натуральное число

k

k

(1≤k

(1≤k

.

Формат выходных данных

Необxодимо вывести измененный массив.

Примеры

входные данные

выходные данные

5

4 5 3 1 2

2

4 2 5 3 1.

Ответить на вопрос
Ответы (1)
Enetimmu 12 мар. 2022 г., 06:54:29

#include

#include

#include

using namespace std ;

mt19937 gen(time(0)) ;

uniform_int_distribution uid(0, 19) ;

void replace(int * a, int n, int k)

{

int last = a[n] ;

for (int i = n - 1 ; i > = k ; i - - ) {

a[i + 1] = a[i] ;

}

a[k] = last ;

}

int main()

{

int n = 0, k = 0 ;

cin >> n ;

int * a = new int[n] ;

if (n.

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Ka2017 18 янв. 2022 г., 16:31:00 | 5 - 9 классы

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHONНа сковородку одновременно можно положить k котлет?

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON

На сковородку одновременно можно положить k котлет.

Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно.

За какое наименьшее время удастся поджарить с обеих сторон n котлет?

Входные данные

Вводятся 3 числа : k, m и n.

Все числа не превосходят 32000.

Выходные данные

Вывести время, за которое все котлеты будут обжарены.

Примеры

Входные данные

1

5

1

Выходные данные

10.

SOLNZETIM 1 мар. 2022 г., 14:15:41 | 5 - 9 классы

Дано неотрицательное число N - количество элементов массива (N?

Дано неотрицательное число N - количество элементов массива (N.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Наташа526 4 февр. 2022 г., 10:53:57 | 5 - 9 классы

Дано N целых чисел?

Дано N целых чисел.

Число называется "красивым", если его можно разделить на 3 без остатка.

Вам нужно выбрать таких K "красивых" чисел, чтобы их сумма была минимальна.

Необходимо вывести эту сумму.

Формат ввода :

N K

A[1] A[2] .

A[N]

Ограничения :

1.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

ZATULIN06 8 февр. 2022 г., 19:54:43 | 10 - 11 классы

Программа на с + +Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз?

Программа на с + +

Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.

Входные данные

Первая строка содержит размер массива N .

Во второй строке через пробел задаются N чисел – элементы массива.

Гарантируется, что 0 < N ≤ 10000 .

В третьей строке записано натуральное число K .

Выходные данные

Программа должна вывести все элементы массива, которые встречаются ровно K раз, в порядке возрастания, разделив их пробелами.

Если таких элементов нет, программа должна вывести число 0.

Примеры

входные данные

6

1 2 1 2 1 3

2

выходные данные

2.

NATO1234454500 28 мар. 2022 г., 00:56:59 | 10 - 11 классы

Программа на с + + (срочно)Напишите программу, которая сортирует массив целых чисел и определяет количество различных значений в нём?

Программа на с + + (срочно)

Напишите программу, которая сортирует массив целых чисел и определяет количество различных значений в нём.

Входные данные

Первая строка содержит размер массива N .

Во второй строке через пробел задаются N чисел – элементы массива.

Гарантируется, что 0 < N ≤ 10000 .

Выходные данные

Программа должна вывести в первой строке элементы массива, отсортированного в порядке возрастания, а во второй строке – количество различных чисел в массиве.

Примеры

входные данные

6

6 2 1 3 6 2

выходные данные

1 2 2 3 6 6

4.

Витуша 22 апр. 2022 г., 11:55:07 | 10 - 11 классы

Умоляю, помогите решить пожалуйста?

Умоляю, помогите решить пожалуйста!

1)Задан массив X[1.

N]. Какой оператор надо поставить вместо многоточия, чтобы в результате в переменную nR был записан номер элемента, равного R?

Вводите ответ без пробелов.

NR : = 0 ; for k : = 1 to N do if X[k] = R then begin .

Break end ;

2)Задан массив X[1.

N]. Какой оператор надо поставить вместо многоточия, чтобы найти номер максимального элемента массива в переменной M?

Вводите ответ без пробелов.

M : = 1 ; for k : = 2 to N do if X[k]>X[M] then .

На этой странице находится ответ на вопрос C + +Дан массивaaизnnэлементов?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.