Дано несколько чисел?

Информатика | 5 - 9 классы

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Ответить на вопрос
Ответы (1)
Mevik999 2 мар. 2022 г., 16:36:35

Var n, a, i, s : integer ;

begin

readln(n) ;

s : = 0 ;

for i : = 1 to n do

begin

readln(a) ;

s : = s + a ;

end ;

writeln(s) ;

end.

Пример :

3

12

54

91

157.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Тёма210 14 февр. 2022 г., 03:09:53 | 5 - 9 классы

ДЛЯ ПИТОНАНапишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min?

ДЛЯ ПИТОНА

Напишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min.

Считайте четыре целых числа и выведите их минимум.

Входные данные

Вводятся четыре целых числа.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

4

5

6

7

выходные данные

4.

Tatyanashmi 18 апр. 2022 г., 16:10:09 | 5 - 9 классы

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHONПодсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел?

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Входные данные

Вводится число N, а затем N чисел.

Выходные данные

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Примеры

Входные данные

5

28

0

0

0

0

Выходные данные

4

1

0.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Bulambaev03 4 мар. 2022 г., 20:18:35 | 10 - 11 классы

На питонеВыведите все четные элементы списка?

На питоне

Выведите все четные элементы списка.

Входные данные

Вводится список чисел.

Все числа списка находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1 2 2 3 3 3 4

выходные данные

2 2 4.

Вы находитесь на странице вопроса Дано несколько чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.