Составить программу замены значений переменных a и b ( пусть дано : a = 3 , b = 5 ; требуется получить a = 5, b = 3) Запись команд присваивания a : = b ; b : = a ; приведет к получению неверного резул?

Информатика | 5 - 9 классы

Составить программу замены значений переменных a и b ( пусть дано : a = 3 , b = 5 ; требуется получить a = 5, b = 3) Запись команд присваивания a : = b ; b : = a ; приведет к получению неверного результата : a = b = 5 ( убедитесь в этом!

).

Ответить на вопрос
Ответы (1)
FynxaleranaS 30 мар. 2022 г., 07:10:30

Программа с использованием вспомогательной переменной :

var a, b, c : integer ;

begin

readln(a, b) ;

c : = a ;

a : = b ;

b : = c ;

writeln(a, ' ', b) ;

end.

Пример :

3 5

5 3.

Алинка12344321 12 янв. 2022 г., 11:19:32 | 5 - 9 классы

Пользователь вводит значение переменной X , а программа должна вычислить значение, той переменной которая получилась больше(то есть или только X или только y)?

Пользователь вводит значение переменной X , а программа должна вычислить значение, той переменной которая получилась больше(то есть или только X или только y).

Strawberryyy 6 янв. 2022 г., 03:04:46 | 5 - 9 классы

В результате выполнения оператора переменные получили следующие значения а = 5 с = 25?

В результате выполнения оператора переменные получили следующие значения а = 5 с = 25.

Укажите правильную запись данного оператора : А.

А : = SQR(c) B.

C = sqrt(a) C.

C : = Sqrt(c) D.

C : = sqr(a).

Andreano 31 янв. 2022 г., 00:13:10 | 5 - 9 классы

Запишите значение переменной s, полученное в результате работы следующей программы?

Запишите значение переменной s, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Помоги, срочно!

АришаРассамахина 1 апр. 2022 г., 17:06:34 | 5 - 9 классы

Как обозначается команда присваивания в Pascal ABC?

Как обозначается команда присваивания в Pascal ABC?

Ramzis 19 янв. 2022 г., 00:28:48 | студенческий

Доказывает ли получение правдоподобного результата правильности программы?

Доказывает ли получение правдоподобного результата правильности программы.

Obrien9669 10 янв. 2022 г., 05:04:46 | 5 - 9 классы

Информатика тема "Паскаль"Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения :Screenshot_1?

Информатика тема "Паскаль"

Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения :

Screenshot_1.

Jpg

При любых значениях переменных программа выполняется корректно?

С чем это связано?

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Svvvs 17 янв. 2022 г., 05:35:17 | 5 - 9 классы

Запишите результат выполнеия последовательности команд, если, k - переменные уелого типа ; s, t, p - строковые переменные?

Запишите результат выполнеия последовательности команд, если, k - переменные уелого типа ; s, t, p - строковые переменные.

Ockurovamarina 21 мая 2022 г., 13:29:04 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Mr853 16 февр. 2022 г., 20:54:42 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Вы открыли страницу вопроса Составить программу замены значений переменных a и b ( пусть дано : a = 3 , b = 5 ; требуется получить a = 5, b = 3) Запись команд присваивания a : = b ; b : = a ; приведет к получению неверного резул?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.