Доказывает ли получение правдоподобного результата правильности программы?

Информатика | студенческий

Доказывает ли получение правдоподобного результата правильности программы.

Ответить на вопрос
Ответы (1)
Ник531 19 янв. 2022 г., 00:28:54

Совершенно нет, рассмотрим такую вот программу : К примеру программа должна определять, является ли число положительным, предположим что имеется такая функция :

boolian isNumberMoreThenZero(integer num) / / функция булевая, т.

Е. / / возращает одно из значений - true / false, принемает на вход число

{ boolian result ; / / есть переменная хранящая результат, / / или ответ если пожелаете result = false ; / / по умолчанию он равен false if (num.

Andreano 31 янв. 2022 г., 00:13:10 | 5 - 9 классы

Запишите значение переменной s, полученное в результате работы следующей программы?

Запишите значение переменной s, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Помоги, срочно!

Свинкапепа2003 23 февр. 2022 г., 07:28:07 | 5 - 9 классы

1. Составьте программу для получения изображения двузначного числа с помощью в Gpaph ABC?

1. Составьте программу для получения изображения двузначного числа с помощью в Gpaph ABC.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Demchenko20 22 янв. 2022 г., 21:02:54 | 5 - 9 классы

Составьте пожалуйста программу на Паскале (2)?

Составьте пожалуйста программу на Паскале (2).

Только правильно!

Vika10404 26 янв. 2022 г., 08:23:04 | 5 - 9 классы

Составьте пожалуйста программу на Паскале (1)?

Составьте пожалуйста программу на Паскале (1).

Только правильно!

ДенЗапорожский 30 мар. 2022 г., 07:10:28 | 5 - 9 классы

Составить программу замены значений переменных a и b ( пусть дано : a = 3 , b = 5 ; требуется получить a = 5, b = 3) Запись команд присваивания a : = b ; b : = a ; приведет к получению неверного резул?

Составить программу замены значений переменных a и b ( пусть дано : a = 3 , b = 5 ; требуется получить a = 5, b = 3) Запись команд присваивания a : = b ; b : = a ; приведет к получению неверного результата : a = b = 5 ( убедитесь в этом!

).

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Nigar223 12 янв. 2022 г., 16:17:06 | 10 - 11 классы

Булат недавно усвоил важное правило : если в программе есть открывающая скобка, то где - то после должна быть и закрывающая скобка такого же типа?

Булат недавно усвоил важное правило : если в программе есть открывающая скобка, то где - то после должна быть и закрывающая скобка такого же типа.

Всего в программе Булат использует три типа скобок : «()», «[]» и «{}».

Булат выписал из своей программы все скобки в одну строку в том порядке, в котором они встречаются.

Теперь он просит вас определить, правильно ли он расставил скобки в своей программе, или же он где - то допустил ошибку.

Скобки считаются расставленными в строке правильно, если : 1) строка пуста или состоит лишь из пары соответствующих друг другу скобок, причем открывающая предшествует закрывающей ; 2) строка с правильно расставленными скобками находится заключена между парой соответствующих друг другу скобок, причем открывающая предшествует закрывающей.

Формат входных данных :

В первой строке записана последовательность не более, чем из 1000 символов, состоящая лишь из открывающих и закрывающих скобок трех типов.

Формат результата :

Выведите слово «YES» если последовательность скобок правильная, иначе выведите «NO».

Примеры

Входные данные Результат работы

{()[]{}} YES

{(][)} NO.

Незнайка124 25 мар. 2022 г., 22:06:53 | 5 - 9 классы

Составьте программу, которая вычисляет произведение натуральных чисел от 5 до 10 и выводит на экран результат (ИСПОЛЬЗОВАТЬ ТОЛЬКО ЦИКЛ while)?

Составьте программу, которая вычисляет произведение натуральных чисел от 5 до 10 и выводит на экран результат (ИСПОЛЬЗОВАТЬ ТОЛЬКО ЦИКЛ while).

Kkv22032002 4 июн. 2022 г., 16:06:20 | студенческий

Правильно ли составлена схема к заданной системе?

Правильно ли составлена схема к заданной системе?

Если нет, исправьте пожалуйста.

Напишите программу для Паскаля.

На этой странице вы найдете ответ на вопрос Доказывает ли получение правдоподобного результата правильности программы?. Вопрос соответствует категории Информатика и уровню подготовки учащихся студенческий классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.