Информатика тема "Паскаль"Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения :Screenshot_1?

Информатика | 5 - 9 классы

Информатика тема "Паскаль"

Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения :

Screenshot_1.

Jpg

При любых значениях переменных программа выполняется корректно?

С чем это связано?

Ответить на вопрос
Ответы (1)
Умник543 10 янв. 2022 г., 05:04:51

Var a, b, c, y1, y2, y3 : real ;

begin

readln(a, b, c) ;

y1 : = sqrt(2 * a - 3) / (b - 1) + sqrt(c * c + a * c + a * a) ;

writeln('y1 = ', y1 : 7 : 3) ;

y2 : = sqrt(2 + sqrt(2 + sqrt(b + sqrt(abs(c - a))))) ;

writeln('y2 = ', y2 : 7 : 3) ;

y3 : = 1 / (1 + 1 / (a + (1 - b) / (1 - c))) ;

writeln('y3 = ', y3 : 7 : 3) ;

end.

Пример :

2 5 3

y1 = 4.

609

y2 = 2.

027

y3 = 0.

800

Программа не будет вычислять значения, если :

1) какое - либо подкоренное выражение будет < 0 ;

2) знаменатель какой - либо дроби будет = 0.

(например, при a = 1 ; b = - 1 ; c = 1).

Pikanka2000 21 янв. 2022 г., 07:37:55 | 5 - 9 классы

Программирование Паскаль?

Программирование Паскаль.

Нужно создать программу в которой будет вычисляться площадь основания ЦИЛИНДРА.

Алинка12344321 12 янв. 2022 г., 11:19:32 | 5 - 9 классы

Пользователь вводит значение переменной X , а программа должна вычислить значение, той переменной которая получилась больше(то есть или только X или только y)?

Пользователь вводит значение переменной X , а программа должна вычислить значение, той переменной которая получилась больше(то есть или только X или только y).

Andreano 31 янв. 2022 г., 00:13:10 | 5 - 9 классы

Запишите значение переменной s, полученное в результате работы следующей программы?

Запишите значение переменной s, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Помоги, срочно!

Bonushajon 2 янв. 2022 г., 09:23:59 | 5 - 9 классы

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел?

Напишите программу(на паскале), которая вычисляет сумму всех двузначных положительных нечетных чисел.

Xristenko 21 апр. 2022 г., 09:41:55 | 5 - 9 классы

Напишите программу, которая считывает с клавиатуры последовательно ири строки : название фильма, название кинотеатра и время, после чего выводит на экран "Билет на "[название фильма]" в "[название кин?

Напишите программу, которая считывает с клавиатуры последовательно ири строки : название фильма, название кинотеатра и время, после чего выводит на экран "Билет на "[название фильма]" в "[название кинотеатра]" на [время] забронирован.

Помогите , пожалуйста.

Как вывести значение переменной в кавычках?

LubitelShkoli 6 апр. 2022 г., 03:15:21 | 5 - 9 классы

Напишите программу, вычисляющую количество дней месяца с положительной температурой?

Напишите программу, вычисляющую количество дней месяца с положительной температурой.

Количество ищмерений и значение температуры вводяться с клавиатуры.

Ockurovamarina 21 мая 2022 г., 13:29:04 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Mr853 16 февр. 2022 г., 20:54:42 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Garenskikhyulia 5 февр. 2022 г., 18:42:10 | 5 - 9 классы

Вычислить сумму квадратов трех переменных, введенных с клавиатуры в паскале, создать программу?

Вычислить сумму квадратов трех переменных, введенных с клавиатуры в паскале, создать программу.

Vladuk9666 4 июн. 2022 г., 18:31:49 | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Перед вами страница с вопросом Информатика тема "Паскаль"Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения :Screenshot_1?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.