Помогите решить в паскале, срочно если можно Дано 2 масива : X : (10) i Y (15)?

Информатика | студенческий

Помогите решить в паскале, срочно если можно Дано 2 масива : X : (10) i Y (15).

Получить в массиве Z все элементы массива Y которые не входят в массив X.

Ответить на вопрос
Ответы (1)
Масюсь 30 мар. 2022 г., 01:19:08

Ничего не сказано про повторяющиеся значения.

Если не делать проверку на повторяющиеся значения, то вот программа (проверена на версии ПаскальАВС.

Нет) :

var x : array [1.

10] of integer ; y, z : array [1.

15] of integer ; i, j, k : integer ; f : boolean ; begin / / заполнение и распечатка массива Х for i : = 1 to 10 do begin x[i] : = random(10) + 1 ; write(x[i] : 3) ; end ; writeln ; / / заполнение и распечатка массива У for i : = 1 to 15 do begin y[i] : = random(10) + 1 ; write(y[i] : 3) ; end ; writeln ; / / заполнение массива Z for i : = 1 to 15 do begin f : = true ; for j : = 1 to 10 do if x[j] = y[i] then begin f : = false ; break ; end ; if f then begin k : = k + 1 ; z[k] : = y[i] ; end ; end ; / / распечатка массива Z for i : = 1 to k do write(z[i] : 3) ;

end.

Natasha7305 14 янв. 2022 г., 18:05:39 | 10 - 11 классы

1)Ввести массив A из 25 элементов?

1)Ввести массив A из 25 элементов.

Cформировать массив B из элементов массива А, кратных трем.

2)Даны массив A и B из n элементов.

Cформировать массив C из элементов массивов А и B, чередуя элементы.

Arin4eg 29 янв. 2022 г., 16:08:12 | 5 - 9 классы

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ?

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ!

Даны 2 массива сформированных случайным образом.

Составить программу которая находит сумму минимальных элементов массива

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО.

Daria006 22 янв. 2022 г., 16:14:21 | 5 - 9 классы

Как найти в двумерном массиве наибольшее число этого массива?

Как найти в двумерном массиве наибольшее число этого массива?

Паскаль(.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

Katykolomeiceva 1 апр. 2022 г., 03:07:07 | 5 - 9 классы

Массив - 10 элементов?

Массив - 10 элементов.

Задача :

Удвоить все четные элементы массива.

Все элементы с нечетным номером разделить на первый

элемент массива.

Срочно!

Завтра сдавать Дз.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Anasavel 26 янв. 2022 г., 13:41:28 | 5 - 9 классы

Помогиие плз срочнокак называется номер элемента массива ?

Помогиие плз срочно

как называется номер элемента массива ?

Запишите объявления массивов по их характеристикам : целочисленный массив А[10], нумерация элементов начинается с 10

какие способы заполнения одномерного массива вы знаете?

Miramironova001 19 февр. 2022 г., 05:27:01 | 5 - 9 классы

Помогите срочно?

Помогите срочно!

Нужно набрать программу, которая выводит 2 массива и находит сумму элементов этих массивов.

«Даны два многомерных массива.

Найти их разность С = А - В.

».

AidBag 6 апр. 2022 г., 06:38:49 | 10 - 11 классы

Помогите с паскалем : описать числовой массив на 5 элементов изаполнить его присваиванием любыми числами,распечатать содержимое элементов массива?

Помогите с паскалем : описать числовой массив на 5 элементов и

заполнить его присваиванием любыми числами,

распечатать содержимое элементов массива.

Вы перешли к вопросу Помогите решить в паскале, срочно если можно Дано 2 масива : X : (10) i Y (15)?. Он относится к категории Информатика, для студенческий. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.