Как найти в двумерном массиве наибольшее число этого массива?

Информатика | 5 - 9 классы

Как найти в двумерном массиве наибольшее число этого массива?

Паскаль(.

Ответить на вопрос
Ответы (2)
Тайна10 22 янв. 2022 г., 16:14:24

Объявляем массив a[NxM], maxv - максимальное значение

.

For I : = 1 to n do for j : = 1 to m do maxv : = max(maxv, a[I, j]) ;

writeln(maxv) ;

Satarovaaida12 22 янв. 2022 г., 16:14:27

Program RANETKI_ZNANIJA ; const n = 5 ; m = 6 ; / / размерность 5 на 6 (5 строк 6 столбцов)var a : array[1.

N, 1.

M]of integer ; / / объявляешь двумерный массив 5 на 6 i, j, max : integer ; / / i и j - счетчики, max - максимальное числоbeginwriteln('Матрица : ') ; for i : = 1 to n do / / цикл с вложенным циклом для заполнения массива случайными числамиbegin for j : = 1 to m do begin a[i, j] : = random(50) ; / / заполняешь элементы массива числами от 0 до 50 write(a[i, j] : 4) ; / / : 4 означает четыре пробела между числами end ; writeln ; / / переход на новую строкуend ; writeln ; / / окончательный переход на новую строку{макс в строках}for i : = 1 to n dobegin max : = a[i, 1] ; / / присваиваешь переменной max значение элемента i - тая строка, первый столбец for j : = 1 to m do begin if a[i, j]>max then max : = a[i, j] ; / / сравниваешь каждый элемент массива с числом max / / если элемента массива больше чем max, то присваиваешь max этот элемент end ; writeln('В строке ', i, ' макс = ', max) ; / / выводишь номер строки и значение maxend ; {макс в столбцах}for j : = 1 to m do / / ОБРАТИ ВНИМАНИЕ что этот тот же цикл что и предыдущий, то теперь вместо j стоит i, а вместо i стоит jbegin max : = a[1, j] ; for i : = 1 to n do begin if a[i, j]>max then max : = a[i, j] ; end ; writeln('В столбце ', j, ' макс = ', max) ; end ; readln ; end.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Alinaschamelevy 3 янв. 2022 г., 08:45:15 | 10 - 11 классы

1) Задан массив из N чисел?

1) Задан массив из N чисел.

Найти среднее арифметическое.

2) Найти номер наибольшего элемента массива размером МхN.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

DOON1 8 мар. 2022 г., 03:44:36 | 5 - 9 классы

Сделайте пожалуйста задачи 1, 2 с помощью одномерных массивов Паскаль?

Сделайте пожалуйста задачи 1, 2 с помощью одномерных массивов Паскаль.

Miramironova001 19 февр. 2022 г., 05:27:01 | 5 - 9 классы

Помогите срочно?

Помогите срочно!

Нужно набрать программу, которая выводит 2 массива и находит сумму элементов этих массивов.

«Даны два многомерных массива.

Найти их разность С = А - В.

».

AidBag 6 апр. 2022 г., 06:38:49 | 10 - 11 классы

Помогите с паскалем : описать числовой массив на 5 элементов изаполнить его присваиванием любыми числами,распечатать содержимое элементов массива?

Помогите с паскалем : описать числовой массив на 5 элементов и

заполнить его присваиванием любыми числами,

распечатать содержимое элементов массива.

Марина1806 19 июн. 2022 г., 02:37:13 | 5 - 9 классы

C + +найти наибольший отрицательный элемент массива n(x) и его порядковый номерПомогите, пожалуйста?

C + +

найти наибольший отрицательный элемент массива n(x) и его порядковый номер

Помогите, пожалуйста!

BelonojkinaS 26 апр. 2022 г., 07:23:22 | 5 - 9 классы

Даю 30 балловсроооочно, ребяткиплииизсоставить алглормтм для ввода данных на клавиатуре для двумерного массива?

Даю 30 баллов

сроооочно, ребятки

плиииз

составить алглормтм для ввода данных на клавиатуре для двумерного массива.

Kabidenov 10 апр. 2022 г., 19:05:57 | 5 - 9 классы

Как сделать сумму чисел меньше 10, причем числа находятся в массиве в интервале 1?

Как сделать сумму чисел меньше 10, причем числа находятся в массиве в интервале 1.

1000

(Паскаль).

Вы зашли на страницу вопроса Как найти в двумерном массиве наибольшее число этого массива?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.