1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2?

Информатика | 5 - 9 классы

1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2.

Ответить на вопрос
Ответы (1)
Ґѻӆѻвѻӆѻӎҝӑ 19 янв. 2022 г., 01:56:04

Program z9 ; Var a, del, del_2, i, j : integer ; b, b_2 : string ; Begin write('Введите число - ') ; readln(a) ; del : = 5 ; del_2 : = 2 ; i : = 0 ; j : = 0 ; while (a > = del) do begin if (a mod del = 0) then begin b : = b + del + ' ' ; i : = i + 1 ; end ; del : = del + 10 ; end ; while (a > = del_2) do begin if (a mod del_2 = 0) then begin b_2 : = b_2 + del_2 + ' ' ; j : = j + 1 ; end ; del_2 : = del_2 + 2 ; end ; writeln('Кол - во делителей заканчивающихся на 5 - ', i) ; writeln(b) ; writeln ; writeln('Кол - во делителей заканчивающихся на 2 - ', j) ; writeln(b_2) ; writeln ; End.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

89517768990 2 янв. 2022 г., 17:20:12 | 5 - 9 классы

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N?

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N.

Простым называется натуральное число больше единицы, имеющее только два делителя : единицу и само это число.

Olyska22 14 февр. 2022 г., 07:30:35 | 5 - 9 классы

Написать программу нахождения суммы нечетных элементов из n заданных пользователем?

Написать программу нахождения суммы нечетных элементов из n заданных пользователем.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

010172а 17 февр. 2022 г., 15:30:04 | 10 - 11 классы

Составить программу нахождения количества трехзначных чисел кратных 23?

Составить программу нахождения количества трехзначных чисел кратных 23.

Dim250696 21 мар. 2022 г., 00:10:52 | 5 - 9 классы

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа?

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Faleg 5 апр. 2022 г., 10:45:45 | 10 - 11 классы

ПРОГРАММА НА С + +Найдите самый маленький натуральный делитель числа x, отличный от 1 (2?

ПРОГРАММА НА С + +

Найдите самый маленький натуральный делитель числа x, отличный от 1 (2.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

На этой странице находится вопрос 1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.