Ребят, срочно нужна помощь?

Информатика | 10 - 11 классы

Ребят, срочно нужна помощь.

Нужно написать программы на языке паскаль

1.

Вводится натуральное число N и цифра A.

Требуется получить новое число N1, вычеркивая из числа N цифру A.

Например : 1)N = 1215, A = 1 - N1 = 25 ; 2)N = 125, A = 9 - N1 = 125.

2. Вводится натуральное число N.

Получить новое число N1, приписав к числу N само себя.

Например : N = 12 - N1 = 1212.

Ответить на вопрос
Ответы (1)
Almagul2811 6 февр. 2022 г., 08:03:42

Var cout, N1 : integer ;

begin

cout : = 1 ;

N1 : = 0 ;

var N : = readinteger('Введите число N : ') ;

var A : = readinteger('Введите число A : ') ;

while N0 do

begin

if (N mod 10 A) then

begin

N1 : = N1 + N mod 10 * cout ;

cout * = 10 ;

end ;

N : = N div 10 ;

end ;

write(N1) ;

end.

Var N1, cout : integer ;

begin

cout : = 1 ;

var N : = readinteger('Введите число N : ') ;

N1 : = N ;

while N0 do

begin

cout * = 10 ;

N : = N div 10 ;

end ;

N : = N1 * cout + N1 ;

write(N) ;

end.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Гтарист5 24 янв. 2022 г., 17:01:26 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти минимальную цифру и приписать её в начало и в конец числа(написать программу в паскале).

Yunalichka 14 янв. 2022 г., 00:28:40 | 5 - 9 классы

Напишите программу на языке Паскаль?

Напишите программу на языке Паскаль!

На экран вводится два пятизначных числа.

Найти среднее арифметическое всех четных цифр в наименьшем числе.

Aleksandrmakaro 20 янв. 2022 г., 22:37:13 | 10 - 11 классы

Ребят, срочно нужна помощь?

Ребят, срочно нужна помощь.

Надо написать программу га языке паскаль которая

определяет одинаковые ли цифры стоят в начале и конце числа N.

12364578 12 янв. 2022 г., 08:39:57 | 5 - 9 классы

Нужно на C + +Дано число?

Нужно на C + +

Дано число.

В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным.

В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.

Программа получает на вход одно длинное натуральное число.

Длина числа может достигать 100 цифр.

Программа должна вывести другое натуральное число, удовлетворяющее условиям :

1)Новое число должно отличаться от данного ровно одной цифрой.

2)Новое число должно делиться на 3.

3)Новое число должно быть максимально возможным из всех таких чисел.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

Aoverchuk 16 апр. 2022 г., 08:21:23 | 10 - 11 классы

Составить программу?

Составить программу.

Дано число N нужно поменять порядок цифр в этом числе и вывести его.

Число N вводится с клавиатуры.

Assertivee 1 февр. 2022 г., 23:09:51 | 5 - 9 классы

Дано натуральное число n (n < 9999)?

Дано натуральное число n (n < 9999).

Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр).

Например, в числе 3678 все цифры различны, в числе 0023 — нет.

На этой странице находится вопрос Ребят, срочно нужна помощь?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.