Помогите решить задачу в Delhi?

Информатика | 10 - 11 классы

Помогите решить задачу в Delhi.

Дано трехзначное число, в котором все цифры различны.

Получить шесть чисел, образованных при перестановке цифр заданного числа.

Ответить на вопрос
Ответы (1)
Томирис22 8 янв. 2022 г., 13:45:40

Var a, a1, a2, a3 : integer ;

begin

write('a = ') ;

readln(a) ;

a1 : = a div 100 ;

a2 : = a div 10 mod 10 ;

a3 : = a mod 10 ;

writeln(a, ' ', a1 * 100 + a3 * 10 + a2) ;

writeln(a2 * 100 + a1 * 10 + a3, ' ', a2 * 100 + a3 * 10 + a1) ;

writeln(a3 * 100 + a1 * 10 + a2, ' ', a3 * 100 + a2 * 10 + a1) ;

end.

Пример :

a = 251

251 215

521 512

125 152.

Kochievaanya 27 янв. 2022 г., 05:25:20 | 1 - 4 классы

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль)?

Дано трехзначное число составить программу которая определят кратно ли 3 произведение его цифр ( на языке паскаль).

Dasha29f 10 февр. 2022 г., 20:51:31 | 5 - 9 классы

Дано трехзначное число Х, вводимое с клавиатуры?

Дано трехзначное число Х, вводимое с клавиатуры.

Первую цифру этого числа перенесли в конец.

Вывести на экран полученное число.

( работать в паскале).

Kirill9930 12 мар. 2022 г., 11:01:01 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Вывести число, полученное при перестановке цифр сотен и десятков исходного числа (например, 123 перейдет в 213) в С + +.

Anyaonishhenko 18 мар. 2022 г., 19:50:54 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы цифре сотен числа а, увеличенной на цифру единиц числа а, число десятков в b обнулить, а вместо единиц поставить число десятков от числа а.

Moisheliv 25 янв. 2022 г., 11:16:50 | 1 - 4 классы

Какие трехзначные числа можно составить из цифр 0, 1, 2?

Какие трехзначные числа можно составить из цифр 0, 1, 2?

Решите задачу, достроив дерево возможных ответов.

ATURATPEVA 14 февр. 2022 г., 17:01:15 | 1 - 4 классы

Какие трехзначные числа можно составить из цифр 0, 1, 2?

Какие трехзначные числа можно составить из цифр 0, 1, 2?

Решите задачу, достроив дерево возможных вариантов.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Coollyudmila202 11 апр. 2022 г., 05:34:32 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

Assertivee 1 февр. 2022 г., 23:09:51 | 5 - 9 классы

Дано натуральное число n (n < 9999)?

Дано натуральное число n (n < 9999).

Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр).

Например, в числе 3678 все цифры различны, в числе 0023 — нет.

Vasinsasha92 23 мая 2022 г., 15:45:55 | 10 - 11 классы

35 балов?

35 балов!

Помогите пожалуйста с информатикой, решить задачи в бейсике.

1)дано целое число, определить оканчивается ли оно чётной цифрой.

2) проверить.

Принадлежит ли число , введённое с клавиатуры.

Интервалу ( - 5, 3).

3) дано двузначное число.

Определить является ли его сумма цифр двузначным числом.

4) дано двузначное число, определить больше ли числа А сумма его цифр.

5) дано двузначное число, определить кратна ли трём сумма его цифр.

6) дано двузначное число.

Определить кратна ли сумма его цифр числу А.

7)дано двузначное число.

Определить водит ли в него цифра 3.

8)дано двузначное число определить какая из его цифр больше : первая или вторая.

9)даны 4 вещественных числа.

Определить сколько из них отрицательных.

На этой странице находится вопрос Помогите решить задачу в Delhi?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.