Помогите пожалуйста написать програму по задаче для Паскаля?

Информатика | 5 - 9 классы

Помогите пожалуйста написать програму по задаче для Паскаля.

Определить количество сетки (b), которой необходимо загородить сад прямоугольной формы, со сторонами а и b метров и количество минеральных удобрений (d) для сада, если их выход (с) килограмм на метр квадратный.

А : = 24

b : = 50

c : = 2.

5.

Ответить на вопрос
Ответы (1)
Butaxin 1 янв. 2022 г., 21:33:47

Var a, b, s, c, d : real ;

begin

write('a, b : ') ;

readln(a, b) ;

write('c : ') ;

readln(c) ;

s : = 2 * (a + b) ;

writeln('Количество сетки : ', s : 5 : 1, ' м') ;

d : = a * b * c ;

writeln('Количество минеральных удобрений : ', d : 5 : 1, ' кг') ;

end.

Пример :

a, b : 24 50

c : 2.

5

Количество сетки : 148.

0 м

Количество минеральных удобрений : 3000.

0 кг

Или так (без ввода данных) :

var a, b, s, c, d : real ;

begin

a : = 24 ;

b : = 50 ;

c : = 2.

5 ;

s : = 2 * (a + b) ;

writeln('Количество сетки : ', s : 5 : 1, ' м') ;

d : = a * b * c ;

writeln('Количество минеральных удобрений : ', d : 5 : 1, ' кг') ;

end.

Результат :

Количество сетки : 148.

0 м

Количество минеральных удобрений : 3000.

0 кг.

Юалоаоа 3 янв. 2022 г., 06:30:22 | 10 - 11 классы

На паскале?

На паскале.

Найти количество чисел которые делятся на 4 в указанном промежутке использовать цикл for.

Софья91 16 янв. 2022 г., 20:45:00 | 10 - 11 классы

Количество информации в сообщении — алфавитный подход Приветствие участникам олимпиады : ТЕВИРИПК?

Количество информации в сообщении — алфавитный подход Приветствие участникам олимпиады : ТЕВИРИПК!

К! написано с помощью символов алфавита : ВЕИКПР!

Т Определить количество информации в этом сообщении?

Привести подробное решение задачи.

2004Алинка2004 22 мар. 2022 г., 22:04:03 | 10 - 11 классы

Дан прямоугольник со сторонами, параллельными сторонам сетки?

Дан прямоугольник со сторонами, параллельными сторонам сетки.

Количество узлов сетки внутри него равно 437472, количество единичных отрезков сетки внутри него равно 877177.

Найдите стороны прямоугольника.

В качестве ответа выведите длины сторон прямоугольника, разделяя их одинарным пробелом, в порядке возрастания, например, 12 23.

Жаклин346 8 февр. 2022 г., 23:44:10 | 5 - 9 классы

Лужайка в парке имеет форму прямоугольника размером а * b метров?

Лужайка в парке имеет форму прямоугольника размером а * b метров.

Разбитого на квадраты со стороной 1 метр.

Необходимо поставить внутри лужайки ограждения между некоторыми квадратами так, чтобы образовались спиральные дорожки, закручивающиеся к центру лужайки.

Определите длину такого ограждения.

Smoki110 5 янв. 2022 г., 10:37:48 | 5 - 9 классы

Задача 1?

Задача 1.

Спиральная дорожка.

Лужайка в парке имеет форму прямоугольника размером а * b метров, разбитого на квадраты со стороной 1 метр.

Необходимо поставить внутри лужайки огрождения между некотороми квадратами так чтобы образовалась спиральная дорожка, закручающаяся к центру лужайки.

Опредеделите длину такого ограждения.

На рисунке изобрежена лужайка размером 4 * 6 и ограждение.

Которое необходимо поставить на ней.

Длина ограждения для такой лужайки будет равна 15.

Elistratova4 18 янв. 2022 г., 00:23:17 | 5 - 9 классы

Лужайка в парке имеет форму прямоугольника размером a * b метров разбитого на квадраты со стороной 1 метр?

Лужайка в парке имеет форму прямоугольника размером a * b метров разбитого на квадраты со стороной 1 метр.

Необходимо поставить внутри лужайки ограждения между некоторыми квадратами так что бы образовалась спиральная дорожкаа закручивающаяся к центру лужайки.

Опредилите длину такого ограждения.

Помогите пж.

Treydbiznes 11 мая 2022 г., 02:27:36 | 5 - 9 классы

Определите стоимость покупки и размер сдачи?

Определите стоимость покупки и размер сдачи.

Цена товара, количество купленных килограмм и количество поданных кассиру денег вводятся с клавиатуры.

ДЭВИД05 11 июн. 2022 г., 17:13:22 | 10 - 11 классы

Помогите написать программу (в паскале) к задаче : Вычислить диагональ прямоугольника если известна меньше сторона, а большая сторона в 3 раза больше за меньшую?

Помогите написать программу (в паскале) к задаче : Вычислить диагональ прямоугольника если известна меньше сторона, а большая сторона в 3 раза больше за меньшую.

Аргон 10 февр. 2022 г., 15:16:46 | 5 - 9 классы

Программа, которая получает длину и ширину одной плитки, размеры стены ицену за один квадратный метр плитки?

Программа, которая получает длину и ширину одной плитки, размеры стены и

цену за один квадратный метр плитки.

Считает необходимое количество плиток и

общую сумму, которую нужно заплатить.

Ayz12ktn 12 мар. 2022 г., 04:45:19 | 5 - 9 классы

Помогите найти количество нечетных делителей числа в паскале?

Помогите найти количество нечетных делителей числа в паскале.

На странице вопроса Помогите пожалуйста написать програму по задаче для Паскаля? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.