Программа, которая получает длину и ширину одной плитки, размеры стены ицену за один квадратный метр плитки?

Информатика | 5 - 9 классы

Программа, которая получает длину и ширину одной плитки, размеры стены и

цену за один квадратный метр плитки.

Считает необходимое количество плиток и

общую сумму, которую нужно заплатить.

Ответить на вопрос
Ответы (2)
Bumerv1998 10 февр. 2022 г., 15:16:52

Varn, m, a, b, cost : integer ;

begin

Readln(a, b) ; / / a - длина плитки, b - ширина

Readln(n, m) ; / / n - длина стены, b - ширина

readln(cost) ; / / стоимость 1й плитки

Writeln((n + a - 1) div a * (m + b - 1)div b, ' ', cost * (n + a - 1) div a * (m + b - 1)div b) ; / / выводит количество плиток и их стоимость

end.

#include

using namespace std ;

int main(){ int a, b ; cin >> a >> b ; int n, m ; cin >> n >> m ; int cost ; cin >> cost ; cout.

Vano4816 10 февр. 2022 г., 15:16:56

Var StenaH, StenaW, plH, plW, temp, cena : real ;

begin

Writeln('Введите размеры стены HxW, размеры плитки HxW В САНТИМЕТРАХ, цену В РУБЛЯХ : ') ;

readln(StenaH, StenaW, plH, plW, cena) ;

temp : = (trunc(StenaH / plH) + 1) * (trunc(StenaW / plW) + 1) ;

writeln('Количество плитки на стену : ', temp, ' цена за все : ', temp * cena, ' рублей') ;

end.

Ыаглщрмг 2 февр. 2022 г., 02:50:56 | 10 - 11 классы

Какие то программу, которая считает в строке все символы А и заменяет их на символ ВВ паскале?

Какие то программу, которая считает в строке все символы А и заменяет их на символ В

В паскале.

Vladislav198 1 янв. 2022 г., 21:33:43 | 5 - 9 классы

Помогите пожалуйста написать програму по задаче для Паскаля?

Помогите пожалуйста написать програму по задаче для Паскаля.

Определить количество сетки (b), которой необходимо загородить сад прямоугольной формы, со сторонами а и b метров и количество минеральных удобрений (d) для сада, если их выход (с) килограмм на метр квадратный.

А : = 24

b : = 50

c : = 2.

5.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Люциус 14 мар. 2022 г., 23:38:53 | 1 - 4 классы

Робот движется вдоль стены, профиль которой показан на рисунке, от начального положения (◊) до конца стены?

Робот движется вдоль стены, профиль которой показан на рисунке, от начального положения (◊) до конца стены.

Необходимо закрасить все внутренние углы стены, как показано на примере.

Размеры стены могут быть произвольны.

Ahiskali 11 апр. 2022 г., 06:09:24 | 5 - 9 классы

Написать программу, которая вычисляет дискриминант квадратного уравнения?

Написать программу, которая вычисляет дискриминант квадратного уравнения.

Anbushinova99 11 апр. 2022 г., 15:33:45 | 5 - 9 классы

Программа получает на вход количество чисел в последовательности, а затем сами числа?

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000.

Введённые числа по модулью не превышают 30 000.

Программа должна вывести одно число : сумму чисел, кратных 7 и оканчивающихся на 4.

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

Kostan 6 апр. 2022 г., 04:14:54 | 5 - 9 классы

Помогите написать программу для решения этой задачи на паскале : "хватит ли N = 180 штук кафельной плитки шириной A = 0, 2 м шириной B = 0, 3 м для покрытия пола в помещении площадью S = 12 м²?

Помогите написать программу для решения этой задачи на паскале : "хватит ли N = 180 штук кафельной плитки шириной A = 0, 2 м шириной B = 0, 3 м для покрытия пола в помещении площадью S = 12 м²?

".

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

На этой странице сайта вы найдете ответы на вопрос Программа, которая получает длину и ширину одной плитки, размеры стены ицену за один квадратный метр плитки?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.