С клавиатуры вводится строка?

Информатика | 5 - 9 классы

С клавиатуры вводится строка.

Подсчитать в ней количество слов.

Pascal ABC.

Ответить на вопрос
Ответы (1)
Mikolaenko1999 6 янв. 2022 г., 22:42:15

Эта программа позволяет находить количество слов в предложении, если слова разделены одним пробелом :

Var s : string ; i, k : integer ;

Begin writeln('Введите строку') ; readln(s) ; k : = 0 ; for i : = 1 to length(s) do begin if s[i] = ' ' then k : = k + 1 ; end ; writeln('Количество слов в предложении = ', k + 1) ;

end.

А эта программа позволяет находить количество слов в предложении, если слова разделены одним или несколькими пробелами :

var s : string ; i, k : integer ;

begin k : = 0 ; writeln('Введите строку : ') ; readln(s) ; s : = ' ' + s ; for i : = 1 to length(s) - 1 do if (s[i] = ' ') and (s[i + 1] ' ') then k : = k + 1 ; writeln(k)

end.

Фишка056 1 мар. 2022 г., 18:36:48 | студенческий

Создать двумерный массив согласно заданию в таблице?

Создать двумерный массив согласно заданию в таблице.

Количество строк n и количество столбцов m (n и m - целые положительные числа) вводится с клавиатуры.

Заполнить массив случайными значениями.

Вывести на экран заполненный массив в виде таблицы.

Timewatersmile 16 февр. 2022 г., 11:50:45 | 10 - 11 классы

ПАСКАЛЬС клавиатуры вводится строка, состоящая из слов на русском языке, отделённых друг от друга одним пробелом?

ПАСКАЛЬ

С клавиатуры вводится строка, состоящая из слов на русском языке, отделённых друг от друга одним пробелом.

Все буквы прописные.

Вывести эту строку на экран, заменив в каждом слове первую букву на заглавную.

Marinazhekovar 20 мар. 2022 г., 10:22:12 | студенческий

На языке Pascal ABC?

На языке Pascal ABC.

Никусик2005 11 февр. 2022 г., 23:05:25 | 5 - 9 классы

Pascal ABC кто разбирается, задание очень сложное?

Pascal ABC кто разбирается, задание очень сложное.

Дана строка содержащая любые символы кроме русских букв.

Под "словом" будем понимать последовательность символов, ограниченную пробелами или стоящую в конце или начале строки.

Между словами может быть несколько пробелов.

Так же пробелы могут быть в конце или начале строки.

Написать функцию, которая в заданной строке находит количество cлов - палиндромов.

Использовать заголовок :

function CalcWord(Stroka : string) : integer ;

Esuratova 26 мар. 2022 г., 13:45:51 | студенческий

Pascal abc помогите решить?

Pascal abc помогите решить.

Katyushkapugin 16 февр. 2022 г., 21:47:00 | 5 - 9 классы

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением ?

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением .

Txt

Pascal ABC.

ТаняКарпухина 12 мар. 2022 г., 02:11:58 | 1 - 4 классы

Pascal ABCНапишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером?

Pascal ABC

Напишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером.

Формат ввода : s - строка i - целое число Формат вывода : s[i] - i - тый символ строки s

Пример ввода : string 2

Пример вывода : t.

Hjbfjhfbjh 6 февр. 2022 г., 02:20:51 | 5 - 9 классы

Тема массивы?

Тема массивы.

Язык - pascal abc.

Нужна программа по принципу работы Вводим 10 элементов массива - выводятся нечетные.

Treydbiznes 11 мая 2022 г., 02:27:36 | 5 - 9 классы

Определите стоимость покупки и размер сдачи?

Определите стоимость покупки и размер сдачи.

Цена товара, количество купленных килограмм и количество поданных кассиру денег вводятся с клавиатуры.

Alina131290 3 мая 2022 г., 07:42:53 | 5 - 9 классы

Помогите, пж с Python?

Помогите, пж с Python!

Напишите программу, которая находит рекордное количество вхождений (не обязательно подряд) символа в строку.

Формат ввода

Вводится одна строка.

Формат вывода

Выводится одно целое число — максимальное количество раз, которое встречается какая - либо буква (без учёта регистра) или иной символ во введённой строке.

Пример

Ввод :

Длинношеееед

Вывод :

4.

На этой странице сайта, в категории Информатика размещен ответ на вопрос С клавиатуры вводится строка?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.