Pascal ABCНапишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером?

Информатика | 1 - 4 классы

Pascal ABC

Напишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером.

Формат ввода : s - строка i - целое число Формат вывода : s[i] - i - тый символ строки s

Пример ввода : string 2

Пример вывода : t.

Ответить на вопрос
Ответы (1)
Darhuck13 12 мар. 2022 г., 02:12:04

/ / PascalABC.

Net v.

3. 2, сборка 1325 (19.

10. 2016)

Var s : string ; i : longint ;

Begin readln(s) ; readln(i) ; writeln(s[i]) ;

End.

Asguol12 6 янв. 2022 г., 22:42:13 | 5 - 9 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

Подсчитать в ней количество слов.

Pascal ABC.

Ыаглщрмг 2 февр. 2022 г., 02:50:56 | 10 - 11 классы

Какие то программу, которая считает в строке все символы А и заменяет их на символ ВВ паскале?

Какие то программу, которая считает в строке все символы А и заменяет их на символ В

В паскале.

Никусик2005 11 февр. 2022 г., 23:05:25 | 5 - 9 классы

Pascal ABC кто разбирается, задание очень сложное?

Pascal ABC кто разбирается, задание очень сложное.

Дана строка содержащая любые символы кроме русских букв.

Под "словом" будем понимать последовательность символов, ограниченную пробелами или стоящую в конце или начале строки.

Между словами может быть несколько пробелов.

Так же пробелы могут быть в конце или начале строки.

Написать функцию, которая в заданной строке находит количество cлов - палиндромов.

Использовать заголовок :

function CalcWord(Stroka : string) : integer ;

Hellp99 24 апр. 2022 г., 23:08:52 | 10 - 11 классы

У Робота есть строка, состоящая из латинских строчных букв a, b, c?

У Робота есть строка, состоящая из латинских строчных букв a, b, c.

Он сокращает эту строку по следующему правилу : просматривает ее слева направо, если встречает четыре подряд идущие символа типа XOXO (вместо X стоит один и тот же символ, вместо O стоит один и тот же символ, отличный от X, например, abab или caca), он их удаляет, “склеивая” оставшуюся строку в месте разрыва.

После удаления символов Робот возвращается к началу строки и опять просматривает ее слева направо и т.

Д, пока пройдя по строке он не сможет найти подстроки, которую можно удалить.

Например, из строки ababcbcbb после первого просмотра робота получится строка cbcbb, а после второго строка b.

У Робота была строка, которую такими действиями можно полностью удалить.

Однако из нее случайно стерли одну букву.

Вот, что осталось :

bcababbccbcbababcaabcbcbabc

Помогите Роботу восстановить строку.

В качестве ответа нужно вывести пару буква и число, разделенные пробелом, где буква – это потерянная буква (латинская строчная a, b или c), а число – номер этой буквы в строке.

Если вариантов несколько, выведите тот, где номер буквы наименьший.

Пример.

Если бы вам была дана строка abb, то ответ был бы таким : a 3.

Katyushkapugin 16 февр. 2022 г., 21:47:00 | 5 - 9 классы

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением ?

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением .

Txt

Pascal ABC.

MashaBalerinka 27 февр. 2022 г., 10:42:31 | 5 - 9 классы

Помогите написать программу, которая определяет, кратное ли число четырём?

Помогите написать программу, которая определяет, кратное ли число четырём.

На Pascal ABC и C + +

Пример :

Ввод Вывод

32 Кратно 4

19 Не кратно 4.

Солюся 6 февр. 2022 г., 22:00:18 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Составьте программу, которая позволяет определить код введенного с клавиатуры символа.

Пример ввода :

А (символ)

Пример ввода :

65 (код символа).

Алшм 22 апр. 2022 г., 22:32:39 | 5 - 9 классы

C + + ?

C + + .

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке.

При вводе неверного номера месяца должно быть выведено слово 'NO'.

Роза232 17 февр. 2022 г., 01:15:08 | 5 - 9 классы

(Даю 50 баллов) (Язык программирования не важен) Никита работает на автостоянке?

(Даю 50 баллов) (Язык программирования не важен) Никита работает на автостоянке.

В его обязанности входит запись номеров въезжающих машин.

Это довольно скучное занятие и поэтому Никита решил оптимизировать этот процесс.

Он хочет, чтобы компьютер обрабатывал изображение с камеры перед въездом в автостоянку и записывал номера.

Никита уже написал софт, который обнаруживает на изображении последовательности из шести символов ; осталось только проверять, является ли данная последовательность номером.

Но из - за того, что Никита постоянно отвлекается на запись номеров, он просит вас о помощи.

Автомобильный номер – строка из шести символов.

Первый символ – заглавная латинская буква, далее следует 3 цифры, и после – две заглавные латинские буквы.

Например, строка "P142EQ" является номером.

Вам будет дана строка, состоящая из шести символов, необходимо ответить, является ли строка автомобильным номером.

Формат входных данных : В единственной строке находится строка из шести символов, состоящая из цифр и заглавных латинских букв.

Формат выходных данных : Если строка является автомобильным номером, то необходимо вывести "Yes", в ином случае – "No" без кавычек.

Sample Input 1 : K040LE Sample Output 1 : Yes Sample Input 2 : M3239L Sample Output 2 : No

Программирование—Напишите программу.

Тестируется через stdin → stdout.

Alina131290 3 мая 2022 г., 07:42:53 | 5 - 9 классы

Помогите, пж с Python?

Помогите, пж с Python!

Напишите программу, которая находит рекордное количество вхождений (не обязательно подряд) символа в строку.

Формат ввода

Вводится одна строка.

Формат вывода

Выводится одно целое число — максимальное количество раз, которое встречается какая - либо буква (без учёта регистра) или иной символ во введённой строке.

Пример

Ввод :

Длинношеееед

Вывод :

4.

На этой странице находится вопрос Pascal ABCНапишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 1 - 4 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.