Это надо делать в Паскале?

Информатика | 5 - 9 классы

Это надо делать в Паскале!

Хеееелп!

Ответить на вопрос
Ответы (1)
Alinolka 23 мая 2021 г., 23:53:11

Function dl(x1, x2, y1, y2 : integer) : integer ;

begin

dl : = trunc(sqrt(sqr(y2 - y1) + sqr(x2 - x1))) ;

end ;

var

p2, a, b, c, d, x1, x2, x3, x4, y1, y2, y3, y4 : integer ;

poly1, poly2, s1, s2, s : real ;

begin

readln(x1, y1) ;

readln(x2, y2) ;

readln(x3, y3) ;

readln(x4, y4) ;

a : = dl(x1, y1, x2, y2) ;

b : = dl(x2, y2, x3, y3) ;

c : = dl(x3, y3, x4, y4) ;

d : = dl(x4, y4, x1, y1) ;

poly1 : = (a + b + c) / 2 ;

poly2 : = (a + c + d) / 2 ;

S1 : = sqrt(poly1 * (poly1 - a) * (poly1 - b) * (poly1 - c)) ;

s2 : = sqrt(poly2 * (poly1 - a) * (poly2 - c) * (poly2 - d)) ;

s : = S1 + s2 ;

writeln(s : 1 : 1) ;

readln ;

end.

Kostyakhakimov 23 июн. 2021 г., 07:15:31 | 5 - 9 классы

Что ввести в начале программы в паскале помогите пж срочно надо и делаю я правильно?

Что ввести в начале программы в паскале помогите пж срочно надо и делаю я правильно?

Решите12 18 янв. 2021 г., 05:27:19 | 10 - 11 классы

Решите пожалуйста Начали Паскаль, а я не оч понимаю как делать, о оценки исправлять надо Заранее спасибо?

Решите пожалуйста Начали Паскаль, а я не оч понимаю как делать, о оценки исправлять надо Заранее спасибо.

AdaFa06 27 июл. 2021 г., 01:06:01 | 10 - 11 классы

Вводится строка?

Вводится строка.

Сколько в строке больших и маленьких латинских букв 'А'?

Прошууу помогите.

Хотя бы скажите как делать я сделаю.

Спасибо всем кто не пролистал.

))Это в паскале.

Амина200522 10 авг. 2021 г., 20:14:04 | 5 - 9 классы

Напишите программу в Паскаль для этих трех задач?

Напишите программу в Паскаль для этих трех задач.

EseniyaMaster 9 февр. 2021 г., 01:48:56 | 5 - 9 классы

Это походу проблемы паскаля?

Это походу проблемы паскаля.

Ushka87 22 июн. 2021 г., 06:36:18 | 5 - 9 классы

Составьте программу ПОЖАЛУЙСТА в PASCAL ABC?

Составьте программу ПОЖАЛУЙСТА в PASCAL ABC.

Вот типа такой цветочек.

Я так понял что эти лепестки надо либо эллипсами либо дугами делать, но не получается ХЕЕЕЕЛП.

GZheka 19 мая 2021 г., 00:49:58 | 10 - 11 классы

Решите это Паскаль АBC?

Решите это Паскаль АBC.

Deadmoo 22 апр. 2021 г., 09:32:03 | 5 - 9 классы

Как в паскале делать вычитания и умножения?

Как в паскале делать вычитания и умножения?

Wasek29rus 24 мар. 2021 г., 14:54:35 | 5 - 9 классы

В программе паскаль, там где окно ввода, после "мой повелитель" должно стоять мое имя?

В программе паскаль, там где окно ввода, после "мой повелитель" должно стоять мое имя.

Что я делаю не так?

Помогите пожалуйста.

Mihon001 2 дек. 2021 г., 02:19:38 | студенческий

Как это работает ?

Как это работает ?

Паскаль

срочно.

Вопрос Это надо делать в Паскале?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.