Решите задачи : 1) Составьте программу ввода элементов массива [1?

Информатика | 10 - 11 классы

Решите задачи : 1) Составьте программу ввода элементов массива [1.

8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.

2) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.

3) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.

4) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Ответить на вопрос
Ответы (1)
Rusik30 7 авг. 2020 г., 02:55:29

1)

uses crt ;

const n = 8 ;

var i : integer ;

a : array[1.

N] of integer ;

begin

writeln('Input elements.

') ;

for i : = 1 to n do

read(a[i]) ;

for i : = 1 to n do

if a[i]< ; 0 then

write(a[i], ' ') ;

end.

2)

uses crt ;

const n = 10 ;

var i, t : integer ;

a : array[1.

N] of integer ;

begin

randomize ;

t : = 0 ;

write('Массив : ') ;

for i : = 1 to n do

begin

a[i] : = random(10, 1) ;

write(a[i], ' ') ;

if a[i] mod 2 = 0 then

t : = t + 1 ;

end ;

writeln(#13#10, t) ;

end.

3)

uses crt ;

const n = 10 ;

var i, sum, t : integer ;

a : array[1.

N] of integer ;

begin

randomize ;

sum : = 0 ;

t : = 0 ;

write('Массив : ') ;

for i : = 1 to n do

begin

a[i] : = random(10, 1) ;

write(a[i], ' ') ;

if a[i] mod 2 = 0 then

sum : = sum + a[i]

else

t : = t + 1 ;

end ;

writeln(#13#10, sum, ' ', t) ;

end.

4)

uses crt ;

const n = 10 ;

var i : integer ;

a : array[1.

N] of integer ;

begin

randomize ;

for i : = 1 to n do

begin

a[i] : = random(10, 1) ;

write(a[i], ' ') ;

if a[i] mod 2 = 0 then

a[i] : = 2 * a[i]

else

a[i] : = 3 * a[i] ;

end ;

write(#13#10) ;

for i : = 1 to n do

write(a[i], ' ') ;

end.

Strela2015 15 февр. 2020 г., 00:37:13 | 5 - 9 классы

4 а) составьте программу , которая заполняет массив а[1?

4 а) составьте программу , которая заполняет массив а[1.

10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами удваиваются , а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массив.

Б)составьте программу , которая заполняет массив b[1.

8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .

Выведите на экран исходный и полученный массивы.

5) а)составьте программу , которая заполняет массив а[1.

10 ] случайными целыми числами в диапозоне от 1 до 10 , и находит количество элементов , которые больше своего соседа слева б)составьте программу , которая заполняет массив b[1.

8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу , которая заполняет массив а[1.

20 ] случайными целыми числами в диапозоне от 1 до 10 , и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

Б) составьте программу , которая заполняет массив b[1.

15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

Mark79 28 авг. 2020 г., 22:47:25 | 5 - 9 классы

A) Составьте программу, которая заполняет массив a[1?

A) Составьте программу, которая заполняет массив a[1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.

Б) Составьте программу, которая заполняет массив b[1.

8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

Къабу 25 сент. 2020 г., 20:11:15 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО составьте программу, которая заполняет массива а [1?

ПОМОГИТЕ СРОЧНО составьте программу, которая заполняет массива а [1.

8] соучайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и суумму элементов массива с нечетными значениями.

AAllii 5 мар. 2020 г., 01:16:54 | 5 - 9 классы

А)Составьте программу ввода элементов массива а[1?

А)Составьте программу ввода элементов массива а[1.

8] с клавиатуры и вывода на экран элементов с отрицательными значениями.

Б)составьте программу, которая заполняет массив b[1.

8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечетными значениями.

Nina1234567 4 мая 2020 г., 21:31:44 | 5 - 9 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Jabaagmerzaev5 26 янв. 2020 г., 12:04:20 | 5 - 9 классы

Составьте программу, которая заполняет массив a [1?

Составьте программу, которая заполняет массив a [1.

10] случайными целыми числами в диапазоне от 1 до 10 а затем элементы с чётными индексами удваивает, а элементы с нечетны

ми индексами утраивает.

Выведите на экран исходный и полученный массивы.

Женя127 22 мар. 2020 г., 18:39:51 | 5 - 9 классы

Помогите пожалуйста) Составьте программу, которая заполняет массив a[1?

Помогите пожалуйста) Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

Ksohina 26 февр. 2020 г., 23:16:51 | 10 - 11 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы массива с нечетными значениями.

Алекс111105 12 окт. 2020 г., 21:47:24 | 5 - 9 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

Бельчонок112 30 сент. 2020 г., 10:47:07 | 5 - 9 классы

Составьте программу, которая заполняет массив [1?

Составьте программу, которая заполняет массив [1.

10] случайными целыми числами в диапазоне от 0 до 10 и находит количество всех четных элементов массива.

Вы зашли на страницу вопроса Решите задачи : 1) Составьте программу ввода элементов массива [1?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.