Pascal : Вычислить значение выражения y = x ^ n – z ^ k?

Информатика | 10 - 11 классы

Pascal : Вычислить значение выражения y = x ^ n – z ^ k.

Вычисление значения степени оформить в виде рекурсии.

Ответить на вопрос
Ответы (1)
Oxanch 2 нояб. 2020 г., 23:05:52

Function Pow(x : real ; n : integer) : real ;

begin if n = 0 then Pow : = 1 else Pow : = Pow(x, n - 1) * x

end ;

var x, z : real ; n, k : integer ;

begin Writeln('Введите x, n, z, k : ') ; Read(x, n, z, k) ; Writeln(Pow(x, n) - Pow(z, k))

end.

Пример

Введите x, n, z, k :

3.

7 5 2.

18 4

670.

85426424.

Lml 11 дек. 2020 г., 20:59:17 | 10 - 11 классы

Вычислить и вывести значения площадей 40 квадратов при различных значениях их сторон (А> ; 0 ) Pascal?

Вычислить и вывести значения площадей 40 квадратов при различных значениях их сторон (А> ; 0 ) Pascal.

ITerraNovaKazanova 22 янв. 2020 г., 14:57:40 | 10 - 11 классы

Определите результаты вычисления выражения (типы и значения) ?

Определите результаты вычисления выражения (типы и значения) :

Добродій 10 дек. 2020 г., 01:43:46 | 5 - 9 классы

. Pascal?

. Pascal.

ABC 1)Вычислить площади двух окружностей и сравнить их.

Оформить вычисление площади окружности в виде процедуры.

2)Вычислить выражение y = x ^ 2 + x ^ 3 + 5 ^ 6 / 3.

Оформить вычисление возведения числа в степень в виде функции.

3) или можно 1 тоже через функцию.

VladaSlobodyan 12 дек. 2020 г., 15:12:58 | 10 - 11 классы

Задание по Паскалю Вычисление математического ожидания оформить в виде процедуры?

Задание по Паскалю Вычисление математического ожидания оформить в виде процедуры.

Ella73 27 янв. 2020 г., 16:58:28 | 5 - 9 классы

Составьте программу вычисления значение выражения, запишите ее в соответствии с правилами Pascal?

Составьте программу вычисления значение выражения, запишите ее в соответствии с правилами Pascal.

ОЧЕНЬ НАДО!

LilyaStress 7 мар. 2020 г., 04:31:00 | 5 - 9 классы

Составить программу вычисления значения выражения?

Составить программу вычисления значения выражения.

ШарикДимарик 29 дек. 2020 г., 16:23:11 | 10 - 11 классы

99Б. Pascal?

99Б. Pascal.

Вычислить значения функции (рисунок) Если не знаете, не пишите.

Ptyika17 30 дек. 2020 г., 05:22:55 | 5 - 9 классы

Turbo Pascal?

Turbo Pascal.

Составить программу.

Вычислить значение функции :

Dimarasher 14 окт. 2020 г., 15:01:02 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Мяусик1 8 нояб. 2020 г., 20:39:47 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

На этой странице сайта вы найдете ответы на вопрос Pascal : Вычислить значение выражения y = x ^ n – z ^ k?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.