Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом?

Информатика | 5 - 9 классы

Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом.

Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.

Входные данные : Во входном потоке задано единственное натуральное число T (T < ; 10000000) Выходные данные : Вывести три натуральных числа через пробел : часов, минут, секунд Пример входного файла (input.

Txt) : 3666.

Ответить на вопрос
Ответы (1)
Innart2012 28 окт. 2020 г., 13:35:59

Var f : Text ; T : longint ; h, m, s, err : integer ; c : string ;

begin Assign(f, 'input.

Txt') ; Reset(f) ; Readln(f, c) ; Val(c, T, err) ; Close(f) ; h : = T div 3600 ; T : = T mod 3600 ; m : = T div 60 ; s : = T mod 60 ; writeln(h, ' ', m, ' ', s)

end.

Тестовое решение :

1 1 6.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Lfitymrf123 8 сент. 2020 г., 10:12:24 | 5 - 9 классы

В кафе продается мороженое по 3 или по 5 шариков в порции?

В кафе продается мороженое по 3 или по 5 шариков в порции.

Определить, можно ли купить K шариков мороженного.

Входные данные : Во входном потоке в первой строке задано натуральное число К (K < ; = 1000) Выходные данные : Вывести YES или NO.

Пример входного файла (input.

Txt) : 2.

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Lstava 29 авг. 2020 г., 16:10:38 | 10 - 11 классы

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток?

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток.

Sergey228989 24 мар. 2020 г., 22:20:56 | 5 - 9 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Входные данные Вводится число n - целое, положительное, не превышает 107.

Выходные данные Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Вы перешли к вопросу Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.