Напишите программу, которая заменяет расширение у заданного имени файла?

Информатика | 5 - 9 классы

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные Первая строка содержит имя файла, которое нужно изменить.

Во второй строке записано нужное расширение.

Выходные данные Программа должна вывести изменённое имя файла с заданным расширением.

Примеры входные данные qwerty exe выходные данные qwerty.

Exe входные данные qwetry.

Old. pas html выходные данные qwetry.

Old. html.

Ответить на вопрос
Ответы (1)
1223n 7 окт. 2020 г., 00:35:37

/ / Pascal ABC.

NET v3.

1 сборка 1219

Var

s, sf : string ;

begin

readln(s) ;

readln(sf) ;

if pos('.

', s)< ; > ; 0 then

delete(s, s.

LastIndexOf('.

') + 2, length(s) - s.

LastIndexOf('.

'))

else

s + = '.

' ;

writeln(concat(s, sf)) ;

end.

Пример ввода :

point.

Simple.

Txt

pdf

Пример вывода :

point.

Simple.

Pdf.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

Vikarumyasha14 7 авг. 2020 г., 03:19:35 | 5 - 9 классы

Заданы два слова?

Заданы два слова.

Составьте программу, которая определит, можно ли вычеркиванием букв из первого слова получить второе.

Входные данные : два слова (а) и (в)

Выходные данные : можно или нельзя.

Целуйкиса 2 авг. 2020 г., 12:14:05 | 5 - 9 классы

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины?

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины.

Используйте процедуру.

Входные данные Входная строка содержит единственное натуральное число – длину линии N .

Выходные данные Программа должна вывести N знаков ' - '.

ПРОГРАММА - PYTHON !

Только PYTHON !

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

ЛизаПоняша 25 дек. 2020 г., 09:24:13 | 10 - 11 классы

Напишите программу, которая возводит натуральное число A в натуральную степень B ?

Напишите программу, которая возводит натуральное число A в натуральную степень B .

Входные данные

Входная строка содержит два числа, A и B , разделённые пробелом.

Гарантируется, что 1 ≤ A , B ≤ 1000 .

Выходные данные

Программа должна вывести одно число : A в степени B .

Примеры

входные данные

2 6

выходные данные

64.

Паскаль ABC 1.

8.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

Вы находитесь на странице вопроса Напишите программу, которая заменяет расширение у заданного имени файла? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.