Дано натуральное число N (1< ; = N< ; = 10000)?

Информатика | 5 - 9 классы

Дано натуральное число N (1< ; = N< ; = 10000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Ответить на вопрос
Ответы (1)
Maksplav 10 февр. 2020 г., 12:22:16

Var s : string ; c1, cn : char ; n : integer ;

begin Write('Введите натуральное число : ') ; Read(n) ; Str(n, s) ; c1 : = s[1] ; cn : = s[Length(s)] ; if c1> ; cn then Writeln('Первая цифра больше последней') else if c1< ; cn then Writeln('Первая цифра меньше последней') else Writeln('Первая и последняя цифры одинаковы')

end.

Тестовые решения

Введите натуральное число : 362336

Первая цифра меньше последней

Введите натуральное число : 7341423

Первая цифра больше последней

Введите натуральное число : 4624

Первая и последняя цифры одинаковы.

Черноключница 9 нояб. 2020 г., 08:18:46 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Составте программу, котора определяет, сколько раз в числе N содержится наибольшая цифра этого числа.

Molokodj3 29 дек. 2020 г., 22:39:45 | 5 - 9 классы

Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени) , где натуральные числа n, а вводятся?

Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени) , где натуральные числа n, а вводятся.

Ответ на паскале.

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

Sofiykas 5 июн. 2020 г., 20:18:17 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить число состоящее из m последних чётных цифр числа n.

Написать программу на Паскале только на Паскале.

Warfacezadrot 6 окт. 2020 г., 01:56:10 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить, какое из его цифр больше : первая или последняя.

Помогитеееее1 25 мая 2020 г., 19:49:19 | 5 - 9 классы

Дано натурального число?

Дано натурального число.

Выведите его последнюю цифру.

Помогите написать программу.

Mysterium 25 июл. 2020 г., 15:46:22 | 10 - 11 классы

1. Дано трехзначное число?

1. Дано трехзначное число.

Написать программу (Pascal), которая «переставляет» первую цифру числа на самое последнее место.

Titan55557 24 июн. 2020 г., 01:32:35 | 5 - 9 классы

Дано пятизначное натуральное число?

Дано пятизначное натуральное число.

Определить его первую и последнюю цифры.

НАСТАСЬЯ0071 20 апр. 2020 г., 04:49:51 | 10 - 11 классы

Дано натуральное число n ?

Дано натуральное число n .

Переставить местами первую и последнюю цифры этого числа.

Inglis1111 12 нояб. 2020 г., 11:31:16 | 5 - 9 классы

Задача?

Задача.

Дано натуральное число N (1< ; = N< ; = 100000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Формат входных данных : В единственной строке задано число N.

Формат выходных данных : В единственной строке необходимо вывести один символ : = , если цифры одинаковые, < ; , если первая цифра меньше последней, > ; , если первая цифра больше последней.

Вы зашли на страницу вопроса Дано натуральное число N (1&lt ; = N&lt ; = 10000)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.