На языке Pascal написать программу Дано натуральное число?

Информатика | 5 - 9 классы

На языке Pascal написать программу Дано натуральное число.

Определить, сколько раз в нём встречается первая цифра.

Задание выполнять с оператором while / Помогите, пожалуйста.

Ответить на вопрос
Ответы (1)
Nata40404 21 авг. 2020 г., 09:19:29

Program prog ;

Uses Crt ;

var n, a, x, k : integer ;

begin

clrscr ;

write('Введите число n = ') ;

readln(n) ;

x : = n ;

while (x> ; 0) do begin a : = x mod 10 ; x : = x div 10 ; end ;

while (n> ; 0) do begin

if (n mod 10) = a then

k : = k + 1 ;

n : = n div 10 ;

end ;

writeln('Цифра ', a, ' встречается ', k, ' раз(а)') ;

end.

MaksimKM 2 июл. 2020 г., 05:05:14 | 10 - 11 классы

Помогите пожалуйста составить программу на языке Pascal?

Помогите пожалуйста составить программу на языке Pascal!

Даны три числа, написать программу, подсчитывающую количество чисел, равных нулю.

Evelinakotova 27 окт. 2020 г., 12:03:08 | 5 - 9 классы

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры?

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры.

(pascal abc).

SKORPIONS1996 28 июл. 2020 г., 03:42:41 | 5 - 9 классы

ПОМОГИИТЕ?

ПОМОГИИТЕ!

Дано натуральное число.

Определить, сколько раз в нем встречается цифра равная последней.

Gulchatayogly 26 апр. 2020 г., 08:30:02 | 5 - 9 классы

Напишите программу на языке программирования (или составьте алгоритм)?

Напишите программу на языке программирования (или составьте алгоритм).

Дано натуральное число n.

Определите, сколько раз цифра «7» встречается в записи данного числа.

Помогитеееее1 25 мая 2020 г., 19:49:19 | 5 - 9 классы

Дано натурального число?

Дано натурального число.

Выведите его последнюю цифру.

Помогите написать программу.

Mysterium 25 июл. 2020 г., 15:46:22 | 10 - 11 классы

1. Дано трехзначное число?

1. Дано трехзначное число.

Написать программу (Pascal), которая «переставляет» первую цифру числа на самое последнее место.

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Alinanna 2 июн. 2020 г., 07:20:10 | 5 - 9 классы

4 «Условный оператор» Написать программу : Дано четырехзначное число?

4 «Условный оператор» Написать программу : Дано четырехзначное число.

Определить, входит ли в него цифра 6.

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

Deaththekid666 7 дек. 2020 г., 21:11:03 | 5 - 9 классы

Помогите пожалуйста найти решение в с + + :Дано натуральное число?

Помогите пожалуйста найти решение в с + + :

Дано натуральное число.

Определить :

а) Количество четных цифр в нем .

Составное условие и более одного неполного условного оператора не использовать.

;

б)сколько раз в нем встречаются цифры 0 и 5(всего) ;

Вы открыли страницу вопроса На языке Pascal написать программу Дано натуральное число?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.