PaskalABC?

Информатика | 5 - 9 классы

PaskalABC.

Вводятся числа от 1 до 9 до тех пор, пока не будет введен 0.

Всего будет введено не больше 100 чисел.

Посчитать количество единиц в этой последовательности, количество двоек, количество троек и так далее (должно выводиться всегда 9 чисел).

Ответить на вопрос
Ответы (1)
КатюшаРождественская 20 июл. 2021 г., 14:39:30

Uses System ;

Var in, out : text ; line, col : integer ; k : integer ;

begin Assign(in, "nome.

In") ; Assign(out, "nomer.

Out") ; Reset(in) ; Rewrite(out) ; Read(in, line, col, k) ; if k < ; col * line theb begin Write(out, (k - 1) div col + 1, ' ', (k - 1) mod col + 1) ; end else Write(out, "слишком большое число") end ; close(in) ; close(out) ;

end.

Pahan1312 18 янв. 2021 г., 20:32:48 | 5 - 9 классы

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем?

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.

(a = 0 признак окончания ввода , ноль не входит в последовательность).

Программа должна вывести количество и сумму всех чисел последовательности.

Chuklinal2016 17 мар. 2021 г., 13:45:40 | 5 - 9 классы

С клавиатуры вводится последовательность чисел необходимо их сумировать пока не будет введено число кратное 2?

С клавиатуры вводится последовательность чисел необходимо их сумировать пока не будет введено число кратное 2.

Результат вывести на экран.

ЗАРАНЕЕ СПАСИБО.

Valeriyatarasova 22 авг. 2021 г., 13:08:23 | 10 - 11 классы

Помогите пжлста?

Помогите пжлста.

Сгенерируйте серию из 10 случайных чисел от 1 до 3 и найдите : а) на сколько количество двоек больше / меньше количества троек, б) количество троек, стоящих на четных местах, в)количество двоек среди первых пяти чисел серии.

Karinaalex56 1 окт. 2021 г., 17:29:10 | 5 - 9 классы

Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0?

Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0.

После ввода нуля, показать на экран количество чисел, которые были введены, их общую сумму и среднее арифметическое.

Срочно!

В Паскале через repeat.

Ехаа 3 мар. 2021 г., 10:12:56 | 5 - 9 классы

Помогите?

Помогите.

Очень срочно надо

Введите N чисел(N предварительно вводится с клавиатуры).

Выведите количество четных.

Оля200518 8 февр. 2021 г., 00:02:52 | 5 - 9 классы

С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5?

С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5.

Подсчитать количество и сумму тех, которые больше 10.

Trolfeisnu 18 сент. 2021 г., 19:01:59 | 5 - 9 классы

Написать программу на языке паскаль?

Написать программу на языке паскаль.

С клавиатуры вводятся несколько натуральных целых чисел.

Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.

Например : вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14.

АртемКириченко 24 апр. 2021 г., 10:30:44 | 5 - 9 классы

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0?

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

Mariya221197 10 мая 2021 г., 10:42:30 | 10 - 11 классы

Вводится последовательность целых чисел до тех пор, пока не будет введено число 0?

Вводится последовательность целых чисел до тех пор, пока не будет введено число 0.

После ввода числа 0 программа должна вывести минимальное число.

Интересует только JAVA или C#.

Дари4чик 25 июн. 2021 г., 12:35:49 | 5 - 9 классы

Посчитать количество введенных чисел пока не будет введено 0?

Посчитать количество введенных чисел пока не будет введено 0.

На этой странице сайта, в категории Информатика размещен ответ на вопрос PaskalABC?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.