Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0?

Информатика | 5 - 9 классы

Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0.

После ввода нуля, показать на экран количество чисел, которые были введены, их общую сумму и среднее арифметическое.

Срочно!

В Паскале через repeat.

Ответить на вопрос
Ответы (1)
Sonja041 1 окт. 2021 г., 17:29:13

Var

a, b, i : integer ;

ar : real ;

begin

b : = 0 ;

repeat read(a) ; b : = b + a ; i : = i + 1 ; until a = 0 ; ar : = b / i ;

writeln('Количество чисел = ', i) ;

writeln('Общая сумма = ', b) ;

writeln('Cреднее арифметическое = ', ar) ; end.

Chuklinal2016 17 мар. 2021 г., 13:45:40 | 5 - 9 классы

С клавиатуры вводится последовательность чисел необходимо их сумировать пока не будет введено число кратное 2?

С клавиатуры вводится последовательность чисел необходимо их сумировать пока не будет введено число кратное 2.

Результат вывести на экран.

ЗАРАНЕЕ СПАСИБО.

Daryapronina 15 февр. 2021 г., 19:25:19 | 10 - 11 классы

Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел?

Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел.

В паскаль.

Anjelika98 27 июн. 2021 г., 14:11:27 | 10 - 11 классы

Для вводимых с клавиатуры чисел определить количество четных чисел исумму нечетных чисел?

Для вводимых с клавиатуры чисел определить количество четных чисел и

сумму нечетных чисел.

Ввод чисел прекращается, когда пользователь вводит

цифру 0.

Gulenkoeva8 20 мая 2021 г., 20:04:20 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

С клавиатуры вводится строка.

Подсчитать и вывести среднее арифметическое цифр в строке.

С клавиатуры вводится строка.

Подсчитать и вывести сумму чисел в строке.

С клавиатуры вводится строка.

Подсчитать и вывести произведение четных чисел в строке, если таких чисел нет, то вывести 0.

AtlasFX 27 февр. 2021 г., 19:31:51 | 1 - 4 классы

Составьте программу?

Составьте программу.

Для вводимых с клавиатуры чисел определить количество положительных.

Ввод чисел прекращается, когда пользователь вводит 0.

Trolfeisnu 18 сент. 2021 г., 19:01:59 | 5 - 9 классы

Написать программу на языке паскаль?

Написать программу на языке паскаль.

С клавиатуры вводятся несколько натуральных целых чисел.

Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.

Например : вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14.

Соф11 10 дек. 2021 г., 00:09:57 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы.

Введённых положительных чисел.

Используйте оператор repeat.

Решить в паскале.

Dd3213 16 мая 2021 г., 01:12:34 | 5 - 9 классы

Написать программу, которая вводит с экрана N чисел, считает их среднее арифметическое и выводит его на экран?

Написать программу, которая вводит с экрана N чисел, считает их среднее арифметическое и выводит его на экран.

АртемКириченко 24 апр. 2021 г., 10:30:44 | 5 - 9 классы

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0?

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

Huggg 8 сент. 2021 г., 10:10:42 | студенческий

Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое?

Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое.

На паскале (через for to do).

На этой странице сайта вы найдете ответы на вопрос Организовать беспрерывный ввод чисел с клавиатуры, пока пользователь не введёт 0?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.