Паскаль?

Информатика | 5 - 9 классы

Паскаль.

Известно, что первые два элемента массива равны a и b.

А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы).

Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных Целые положительное число n (2 Целые числа a, b ( - 50 < ; a, b < ; 50) Формат выходных данных Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел.

Ответить на вопрос
Ответы (1)
KLOKOVA 8 мая 2020 г., 18:54:39

Var

n, a, b, i, j : integer ; ar : array[1.

10000]of integer ; begin read(n, a, b) ; ar[1] : = a ; ar[2] : = b ; for i : = 3 to n do begin for j : = 1 to i - 1 do begin ar[i] : = ar[i] + ar[j] ; end ; ar[i] : = ar[i] + i ; end ; for i : = n downto 1 do write(ar[i], ' ') ;

end.

Makc20 12 июл. 2020 г., 18:50:01 | 10 - 11 классы

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу?

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

На вход программе сначала подается значение n< ; = 100 – количество элементов в массиве.

В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000.

Выдайте количество искомых элементов массива.

Petrusina42 5 июл. 2020 г., 19:55:08 | 10 - 11 классы

Объявить массив размерностью N?

Объявить массив размерностью N.

Заполнить элементы массива.

Распечатать значения элементов массива.

Вывести значения в обратном порядке.

Вывести значения элементов с четными индексами.

EonEGuy1 21 нояб. 2020 г., 08:01:29 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Нумерация элементов начинается с 0.

Выведите все элементы массива с четными номерами.

Формат входных данныхСначала задано число N - количество элементов в массиве, N100.

Далее через пробел записаны N чисел - элементы массива.

Все числа по модулю не превосходят 10000

Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], .

).

Соничкаа 22 авг. 2020 г., 21:51:53 | 5 - 9 классы

Срочно , напишите программуДан массив, состоящий из целых чисел?

Срочно , напишите программу

Дан массив, состоящий из целых чисел.

Нумерация элементов начинается с 0.

Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4.

). Входные данныеСначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данныеНеобходимо вывести все элементы массива с чётными номерами.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Vypusknik2014 6 сент. 2020 г., 15:51:57 | 5 - 9 классы

Дан массив из n элементов?

Дан массив из n элементов.

Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ?

Если есть, то вывести индексы первой такой пары чисел.

Индексация элементов начинаются с единицы Формат входных данных С клавиатуры вводится натуральное число n (n≤100).

На следующей строке через пробел вводятся n элементов массива.

Все числа по модулю не превосходят 100.

В последней строке вводится число k, (−200≤k≤200).

Формат выходных данных В качестве ответа выведите индексы искомых элементов через пробел в порядке возрастания.

Если таких элементов нет, то вывести 0.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Вы перешли к вопросу Паскаль?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.