Дан массив, состоящий из целых чисел?

Информатика | 5 - 9 классы

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры Входные данные 5 1 1 1 1 1 Выходные данные 1.

Ответить на вопрос
Ответы (1)
Арина26 19 янв. 2020 г., 21:00:04

Program X ;

var

mas : array[1.

1000000] of longint ;

N, i, count : longint ;

begin

count : = 1 ;

readln(N) ;

for i : = 1 to N do

read(mas[i]) ;

if N> ; 1 then

begin for i : = 2 to N do if mas[i]< ; > ; mas[i - 1] then inc(count) ; writeln(count)

end else

writeln(1)

end.

Olya06 20 нояб. 2020 г., 13:41:50 | 5 - 9 классы

Помогите написать программу на С + + ?

Помогите написать программу на С + + .

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры входные данные 5 1 1 1 1 1 выходные данные 1.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Алина26032000 21 апр. 2020 г., 02:29:02 | 5 - 9 классы

Сначала задано число N - количество элементов в массиве?

Сначала задано число N - количество элементов в массиве.

Далее через пробел записаны N чисел - элементы массива.

Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).

Badertdinovrus 8 февр. 2020 г., 04:07:52 | 5 - 9 классы

Вводится массив, состоящий из целых чисел?

Вводится массив, состоящий из целых чисел.

Найти наибольшее среди них.

Входные данные Сначала задано число N — количество элементов в массиве (1N35).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести значение наибольшего элемента в массиве.

Примеры Входные данные 3 1 2 3 Выходные данные 3.

EonEGuy1 21 нояб. 2020 г., 08:01:29 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Нумерация элементов начинается с 0.

Выведите все элементы массива с четными номерами.

Формат входных данныхСначала задано число N - количество элементов в массиве, N100.

Далее через пробел записаны N чисел - элементы массива.

Все числа по модулю не превосходят 10000

Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], .

).

Соничкаа 22 авг. 2020 г., 21:51:53 | 5 - 9 классы

Срочно , напишите программуДан массив, состоящий из целых чисел?

Срочно , напишите программу

Дан массив, состоящий из целых чисел.

Нумерация элементов начинается с 0.

Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4.

). Входные данныеСначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данныеНеобходимо вывести все элементы массива с чётными номерами.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Вы открыли страницу вопроса Дан массив, состоящий из целых чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.