Помогите с информатикой 60 баллов?

Информатика | 10 - 11 классы

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

Ответить на вопрос
Ответы (1)
Imamrazyev 14 дек. 2020 г., 23:08:47

Const m = 5 ; n = 7 ;

var a : array[1.

M, 1.

N] of integer ; i, j, amax : integer ; p : real ;

begin Randomize ; Writeln('Исходный массивэ') ; for i : = 1 to m do begin for j : = 1 to n do begin a[i, j] : = Random(90) + 10 ; Write(a[i, j] : 3) end ; Writeln end ; {Задача 1} amax : = a[1, 1] ; for i : = 1 to m do for j : = 1 to n do if a[i, j]> ; amax then amax : = a[i, j] ; Writeln('Максимальный элемент равен ', amax) ; {Задача 2} p : = 1 ; for i : = 1 to m do for j : = 1 to n do if a[i, j] mod 2 = 0 then p : = p * a[i, j] ; Writeln('Произведение четных элементов равно ', p) ;

end.

Пример работы

Исходный массивэ

94 20 49 80 70 55 40

62 74 71 51 88 10 76

68 11 11 74 96 50 69

98 34 25 93 52 53 61

68 85 35 15 77 78 97

Максимальный элемент равен 98

Произведение четных элементов равно 2.

86826492979212E + 33.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Ktibr260 23 янв. 2020 г., 21:05:46 | 5 - 9 классы

Помогите решить задачу : дан двумерный массив?

Помогите решить задачу : дан двумерный массив.

Найти среднее арифметическое четных элементов массива.

(Gambas)!

Mariqka 6 апр. 2020 г., 14:51:06 | 10 - 11 классы

1. Дан двумерный целочисленный массив?

1. Дан двумерный целочисленный массив.

2. размерность массива задается пользователем.

3. случайные числа генерируются из промежутка ( - m, m)

4.

M задается пользователем.

Найти количество нулевых элементов над главной диагональю и Максимальный четный элемент на побочной диагонали.

Gaptrahmanova19 27 дек. 2020 г., 17:04:59 | 5 - 9 классы

Задача по информатике 11 класс, тема двумерный массив?

Задача по информатике 11 класс, тема двумерный массив.

Сформировать двумерный массив с случайными числами и найти сумму всех элементов.

Помогите!

Lizagacenko 27 окт. 2020 г., 19:57:22 | 10 - 11 классы

Помоги пожалуйста?

Помоги пожалуйста!

: * дан двумерный массив вывести на экран все элементы n - й строки массива паскаль.

Jenya932 26 мая 2020 г., 12:10:21 | 10 - 11 классы

HELP?

HELP!

Дан двумерный массив(4 * 5) написать программу, которая определит кол - во четных элементов двумерного массива.

Заполонить с клавиатуры.

Yulia2222222 1 июн. 2020 г., 12:14:15 | 5 - 9 классы

Дан двумерный массив A размерностью М * N?

Дан двумерный массив A размерностью М * N.

Отсортировать все строки по возрастанию значений элементов.

Vse02052004 28 нояб. 2020 г., 06:31:11 | 5 - 9 классы

Задайте двумерный массив размерности 3х3?

Задайте двумерный массив размерности 3х3.

Выведите массив в виде матрицы.

Найдите сумму четных элементов второй строки.

Пвпорлмдоиж 18 нояб. 2020 г., 21:07:54 | 10 - 11 классы

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива?

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива.

Размерность вводится с клавиатуры, массив заполняется случайным образом.

Массив распечатать в виде таблицы(без setlength) помогите пожалуйста, кто тут шарит по информатике!

Alexandrovnakr 26 дек. 2020 г., 16:11:55 | 10 - 11 классы

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива?

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива.

Размерность вводится с клавиатуры, массив заполняется случайным образом.

Массив распечатать в виде таблицы.

Помогите пожалуйста, кто тут шарит по информатике!

На этой странице находится вопрос Помогите с информатикой 60 баллов?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.