1. Дан двумерный целочисленный массив?

Информатика | 10 - 11 классы

1. Дан двумерный целочисленный массив.

2. размерность массива задается пользователем.

3. случайные числа генерируются из промежутка ( - m, m)

4.

M задается пользователем.

Найти количество нулевых элементов над главной диагональю и Максимальный четный элемент на побочной диагонали.

Ответить на вопрос
Ответы (1)
Aselamantai15 6 апр. 2020 г., 14:51:09

Var mas : array [, ] of integer ; i, j, m, n, s, max : integer ; f : boolean ;

begin

write('Введите размерность массива : ') ;

readln(n) ;

write('Введите число m : ') ;

readln(m) ;

setlength(mas, n + 1, n + 1) ;

for i : = 1 to n do begin ; for j : = 1 to n do begin mas[i, j] : = random( - m, m) ; write(mas[i, j] : 6) ; if (j> ; i) and (mas[i, j] = 0) then s : = s + 1 ; end ; writeln ; end ;

j : = n ;

f : = false ;

for i : = 1 to n do begin if (mas[i, j] mod 2 = 0) then begin if f = false then begin max : = mas[i, j] ; f : = true ; end ; if (mas[i, j]> ; max) then max : = mas[i, j] ; end ; j : = j - 1 ; end ;

writeln('Число нулей над гл.

Диагональю : ', s) ;

writeln('Максимальный четный на доп.

Диагонали : ', max) ;

end.

Lyuba1606 30 апр. 2020 г., 15:12:53 | 10 - 11 классы

Дан двумерный массив размерности 10х10?

Дан двумерный массив размерности 10х10.

Заполнить его случайными числами на отрезке [ - 25, 25].

В каждой строке массива найти количество элементов, больших заданного числа H.

Результат получить в виде одномерного массива.

Вывести исходный массив и полученный результат на печать.

Zarolik 23 авг. 2020 г., 08:39:14 | 5 - 9 классы

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива?

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.

Длина массива N задается пользователем как константное выражение.

Исходные данные задать вручную или с помощью генератора случайных чисел, учитывая формат элементов массива А.

Тип результата определяется из контекста.

- Вычислить количество отрицательных элементов массива ; - сумму модулей элементов массива, расположенных после максимального элемента.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Megaalinamail 21 авг. 2020 г., 13:14:46 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Hайти количество элементов массива, превосходящих по модулю заданное число А, изменить знак максимального элемента на противоположный, найти количество элементов массива, кратных 5.

Torigrey72 22 янв. 2020 г., 03:52:11 | 10 - 11 классы

Дана целочисленная прямоугольная матрица?

Дана целочисленная прямоугольная матрица.

Найти сумму элементов тех столбцов, которые содержат хотя бы один отрицательный элемент.

Примечание : Размеры массивов задаются именованными константами.

Значения элементов массивов вводятся с клавиатуры, генерируются случайным образом или инициализируются в программе (значения по умолчанию).

Способ задания элементов массива выбирается пользователем.

Все операции над массивами выполняются отдельными функциями.

Danil311020031 13 окт. 2020 г., 10:19:30 | 10 - 11 классы

ПОМОГИТЕ НАПИСАТЬ КОД, НА ЯЗЫКА СИ?

ПОМОГИТЕ НАПИСАТЬ КОД, НА ЯЗЫКА СИ.

Случайным образом генерируется массив чисел.

Пользователь вводит числа a и b.

Заменить элемент массива на сумму его соседей, если элемент массива четный и номер его лежит в промежутке от a до b.

Prinzessulya 10 окт. 2020 г., 03:37:04 | 10 - 11 классы

Дана целочисленная прямоугольная матрица?

Дана целочисленная прямоугольная матрица.

Найти сумму элементов тех столбцов, которые содержат хотя бы один отрицательный элемент.

Примечание : Размеры массивов задаются именованными константами.

Значения элементов массивов вводятся с клавиатуры, генерируются случайным образом или инициализируются в программе (значения по умолчанию).

Способ задания элементов массива выбирается пользователем.

Все операции над массивами выполняются отдельными функциями.

Nikitos113 9 июл. 2020 г., 17:17:58 | 10 - 11 классы

Составьте программу генерирующую одномерный массив из элементов двумерного массива А(N, N), расположенных над главной диагональю?

Составьте программу генерирующую одномерный массив из элементов двумерного массива А(N, N), расположенных над главной диагональю.

Annst5inabald 14 дек. 2020 г., 23:08:46 | 10 - 11 классы

Помогите с информатикой 60 баллов?

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

2002ru 19 сент. 2020 г., 12:17:56 | 10 - 11 классы

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста?

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста!

))).

Вопрос 1. Дан двумерный целочисленный массив?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.