Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива?

Информатика | 10 - 11 классы

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива.

Размерность вводится с клавиатуры, массив заполняется случайным образом.

Массив распечатать в виде таблицы(без setlength) помогите пожалуйста, кто тут шарит по информатике!

Ответить на вопрос
Ответы (2)
Buranbaeva02 18 нояб. 2020 г., 21:08:00

Var i, n, m, j, max : integer ; ar : array[1.

10000, 1.

10000]of integer ;

begin randomize ; readln(n, m) ; for i : = 1 to n do for j : = 1 to m do begin ar[i, j] : = random(1, 100) ; if(i = 1) and (j = 1) then max : = ar[1, 1] ; if(ar[i, j] > ; max) then max : = ar[i, j] ; end ; writeln('Максимальный элемент : ', max) ; for i : = 1 to n do begin for j : = 1 to m do

write(ar[i, j] : 4, ' ') ; writeln ; end ;

end.

Koteika619 18 нояб. 2020 г., 21:08:03

Var a : array [1.

100, 1.

100] of integer ;

n, m, i, j, max : integer ;

begin

Randomize ;

write('n = ') ;

readln(n) ;

write('m = ') ;

readln(m) ;

writeln('Исходный массив : ') ;

for i : = 1 to n do

begin

for j : = 1 to m do begin a[i, j] : = random(51) ; write(a[i, j] : 4) ; end ; writeln ;

end ;

max : = a[1, 1] ;

for i : = 1 to n do

for j : = 1 to m do if a[i, j]> ; max then max : = a[i, j] ;

writeln('max = ', max) ;

end.

Пример :

n = 4

m = 5

Исходный массив : 32 24 18 0 11 36 46 13 31 36 27 49 14 50 35 9 25 15 35 41

max = 50.

Марта221 11 сент. 2020 г., 01:42:13 | 10 - 11 классы

Заполнить двумерный массив случайными числами?

Заполнить двумерный массив случайными числами.

Размерность массива и диапазон генерации вводятся с клавиатуры.

Составить программу, которая вычисляет сумму всех элементов массива.

Затем организовать новый массив В, в котором заменить отрицательные элементы исходного массива на 1, а значения остальных элементов оставить без изменения.

Подсчитать количество замен.

Maloy22 12 дек. 2020 г., 17:16:22 | 10 - 11 классы

Найти максимальных элемент в массиве размерностью М * Т?

Найти максимальных элемент в массиве размерностью М * Т.

М и N вводятся с клавиатуры.

(Паскаль).

Tati123 25 февр. 2020 г., 11:27:23 | 5 - 9 классы

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры?

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Gaptrahmanova19 27 дек. 2020 г., 17:04:59 | 5 - 9 классы

Задача по информатике 11 класс, тема двумерный массив?

Задача по информатике 11 класс, тема двумерный массив.

Сформировать двумерный массив с случайными числами и найти сумму всех элементов.

Помогите!

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

Annst5inabald 14 дек. 2020 г., 23:08:46 | 10 - 11 классы

Помогите с информатикой 60 баллов?

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

Alexandrovnakr 26 дек. 2020 г., 16:11:55 | 10 - 11 классы

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива?

Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива.

Размерность вводится с клавиатуры, массив заполняется случайным образом.

Массив распечатать в виде таблицы.

Помогите пожалуйста, кто тут шарит по информатике!

Shepard3405 8 нояб. 2020 г., 02:31:01 | 5 - 9 классы

Помогите с информатикой пожалуйста?

Помогите с информатикой пожалуйста!

1)Заполнить массив случайным образом целыми числами на отрезке от - 27 до 27.

Найти минимальный элемент и его индекс.

2)Элементы массива вводят с клавиатуры.

Найти сумму элементов на отрезке от - 5 до 5.

Svetik1992 17 дек. 2020 г., 01:52:25 | 5 - 9 классы

В массиве состоящего из n элементов подсчитать количество положительных элементов больших чем k - вводится с клавиатуры?

В массиве состоящего из n элементов подсчитать количество положительных элементов больших чем k - вводится с клавиатуры.

Массив вводится случайным образом на [0 ; 20].

Паскаль!

Ребята срочно помогите.

На этой странице находится ответ на вопрос Задача Паскаль )))10 класс Найти максимальный элемент двумерного массива?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.