Помогите пожалуйста задачу сделать в паскале?

Информатика | 5 - 9 классы

Помогите пожалуйста задачу сделать в паскале.

Составьте программу, которая удаляет из слова X те буквы, которые встречаются в слове Z.

Слова X и Z вводятся с клавиатуры.

Ответить на вопрос
Ответы (1)
Настия2 26 апр. 2020 г., 08:02:05

Var

x, z : string ;

i : integer ;

ar : array['а'.

'я'] of boolean ;

begin

readln(x) ;

readln(z) ;

for i : = 1 to Length(z) do ar[z[i]] : = true ;

for i : = Length(x) downto 1 do if (ar[x[i]] = true) then delete(x, i - 1, 1) ;

writeln(x) ;

end.

Не забудь отметить лучший ответ ; - ).

Rybyska 12 мар. 2020 г., 10:21:47 | 5 - 9 классы

1. С клавиатуры вводят слово и символ?

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

Alekseeva20044 19 нояб. 2020 г., 21:52:38 | 10 - 11 классы

Программа в Pascal 1?

Программа в Pascal 1.

Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м.

2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о.

Ivanovamarina2 17 мая 2020 г., 02:02:55 | 5 - 9 классы

1. С клавиатуры вводят слово и симвал?

1. С клавиатуры вводят слово и симвал.

Составьте программу , которая а)проверяет, есть ли в этом слове данный симвал.

Б)определяет позицию данного символа.

В)подсчитывает количество входов данного символа.

2. С клавиатуры вводят ряд и слово.

Составьте программу , которая а)определяет позицию данного слова.

Сделайте что сможете пожалуйста!

Рппрь 7 сент. 2020 г., 09:12:57 | 10 - 11 классы

Помогите паскаль?

Помогите паскаль!

Срочно нужно!

20Балов за 4 задачи 3Составте программу , которая определяет , какое из 2 - х слов более длиннее и выводит это слово 4, С клавиатуры вводят 2 слова .

Составте программу, которая выводит на экран слова в обратном порядке 5, С клавиатуры вводят слово .

Составте программу которая выводит количество символов в нем 6, Составте программу , которая определяет какое из 2 - х введенных с клавиатуры слов короче , и выводит это слово.

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Ptardeeva 26 февр. 2020 г., 02:20:21 | 10 - 11 классы

Помогите паскаль?

Помогите паскаль!

Срочно нужно!

20Балов за 4 задачи

3Составте программу , которая определяет , какое из 2 - х слов более длиннее и выводит это слово 4, С клавиатуры вводят 2 слова .

Составте программу, которая выводит на экран слова в обратном порядке 5, С клавиатуры вводят слово .

Составте программу которая выводит количество символов в нем 6, Составте программу , которая определяет какое из 2 - х введенных с клавиатуры слов короче , и выводит это слово.

Идиото 4 апр. 2020 г., 08:03:45 | 10 - 11 классы

1. С клавиатуры вводится слово, распечатать все его буквы через пробел?

1. С клавиатуры вводится слово, распечатать все его буквы через пробел.

(после последней буквы пробела быть не должно).

2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.

Gulzadab79 26 мар. 2020 г., 18:36:01 | 10 - 11 классы

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ?

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.

Слово вводится в программе.

PascalABC.

Valerakot 3 окт. 2020 г., 22:50:23 | 10 - 11 классы

С клавиатуры вводят слово?

С клавиатуры вводят слово.

Составьте программу, которая определяет позицию буквы "е" в слове.

На этой странице находится вопрос Помогите пожалуйста задачу сделать в паскале?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.