Помогите паскаль?

Информатика | 10 - 11 классы

Помогите паскаль!

Срочно нужно!

20Балов за 4 задачи 3Составте программу , которая определяет , какое из 2 - х слов более длиннее и выводит это слово 4, С клавиатуры вводят 2 слова .

Составте программу, которая выводит на экран слова в обратном порядке 5, С клавиатуры вводят слово .

Составте программу которая выводит количество символов в нем 6, Составте программу , которая определяет какое из 2 - х введенных с клавиатуры слов короче , и выводит это слово.

Ответить на вопрос
Ответы (1)
Пемкеа 7 сент. 2020 г., 09:13:03

Со строками можно работать также, как и с элементами массива, т.

Е. мы можем обратиться к любому символу строки, как к элементу, можем сравнивать строки, складывать и вычитать( последние две операции здесь нам не понадобятся)

№3.

Program ex3 ;

var a, b : string ;

k, n, i : integer ; {ввод исходных данных}

begin

writeln('введите первое слово') ;

readln(a) ; {компьютер читает введенное число a}

writeln('введите второе слово') ;

readln(b) ; {компьютер читает введенное число b}

k : = 0 ; {обнуляем переменные k и n, это будут счетчики в данной программе}

n : = 0 ;

for i : = 1 to length(a) do { проверяем символы от первогодо конца строки}

k : = k + 1 ; {если в строке находится символ, то переменная k увеличивается на 1}

for i : = 1 to length(b) do{аналогично}

n : = n + 1 ;

if k> ; n{проверяем, если количество символов в первой строке больше, чем количество символов во второй, то выводим a(первое слово), иначе b (второе слово)}

then

writeln(a)

else

writeln(b) ;

end.

№4program ex4 ;

var a, b : string ;

i : integer ;

begin

writeln('введите первое слово') ;

readln(a) ;

writeln('введите второе слово') ;

readln(b) ;

k : = 0 ;

n : = 0 ;

for i : = length(a) downto 1 do{просматриваю строку в обратном порядке и вывожу каждый символ на экран}

write(a[i]) ;

writeln ;

for i : = length(b) downto 1 do {просматриваю строку в обратном порядке и вывожу каждый символ на экран}

write(b[i]) ;

end.

№5

program ex3 ;

var a : string ;

k, n, i : integer ; {ввод исходных данных}

begin

writeln('введите слово') ;

readln(a) ; {компьютер читает введенное число a}

k : = 0 ; {обнуляем переменные k , это будут счетчики в данной программе}

for i : = 1 to length(a) do { проверяем символы от первогодо конца строки}

k : = k + 1 ; {если в строке находится символ, то переменная k увеличивается на 1}

writeln(k) ;

end.

№6. Задача аналогичная №3, за исключением условия в конце.

Program ex3 ;

var a, b : string ;

k, n, i : integer ; {ввод исходных данных}

begin

writeln('введите первое слово') ;

readln(a) ; {компьютер читает введенное число a}

writeln('введите второе слово') ;

readln(b) ; {компьютер читает введенное число b}

k : = 0 ; {обнуляем переменные k и n, это будут счетчики в данной программе}

n : = 0 ;

for i : = 1 to length(a) do { проверяем символы от первогодо конца строки}

k : = k + 1 ; {если в строке находится символ, то переменная k увеличивается на 1}

for i : = 1 to length(b) do{аналогично}

n : = n + 1 ;

if k< ; n{проверяем, если количество символов в первой строке меньше, чем количество символов во второй, то выводим a(первое слово), иначе b (второе слово)}

then

writeln(a)

else

writeln(b) ;

end.

Rybyska 12 мар. 2020 г., 10:21:47 | 5 - 9 классы

1. С клавиатуры вводят слово и символ?

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

Ivanovamarina2 17 мая 2020 г., 02:02:55 | 5 - 9 классы

1. С клавиатуры вводят слово и симвал?

1. С клавиатуры вводят слово и симвал.

Составьте программу , которая а)проверяет, есть ли в этом слове данный симвал.

Б)определяет позицию данного символа.

В)подсчитывает количество входов данного символа.

2. С клавиатуры вводят ряд и слово.

Составьте программу , которая а)определяет позицию данного слова.

Сделайте что сможете пожалуйста!

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Ptardeeva 26 февр. 2020 г., 02:20:21 | 10 - 11 классы

Помогите паскаль?

Помогите паскаль!

Срочно нужно!

20Балов за 4 задачи

3Составте программу , которая определяет , какое из 2 - х слов более длиннее и выводит это слово 4, С клавиатуры вводят 2 слова .

Составте программу, которая выводит на экран слова в обратном порядке 5, С клавиатуры вводят слово .

Составте программу которая выводит количество символов в нем 6, Составте программу , которая определяет какое из 2 - х введенных с клавиатуры слов короче , и выводит это слово.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Бомбалейло 31 июл. 2020 г., 22:13:27 | 10 - 11 классы

Написать программы на языке С + +1) С клавиатуры вводится 2 числа - целое и вещественное?

Написать программы на языке С + +

1) С клавиатуры вводится 2 числа - целое и вещественное.

Программа выводит их сумму на экран.

2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран

3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом

4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов.

Dasdgffjj 4 апр. 2020 г., 20:51:39 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу.

Составить программу, которая вводит с клавиатуры один символ и выводит на экран два символа стоящие до и после этого символа.

Gulzadab79 26 мар. 2020 г., 18:36:01 | 10 - 11 классы

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ?

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.

Слово вводится в программе.

PascalABC.

Valerakot 3 окт. 2020 г., 22:50:23 | 10 - 11 классы

С клавиатуры вводят слово?

С клавиатуры вводят слово.

Составьте программу, которая определяет позицию буквы "е" в слове.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите паскаль?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.