Дана строка?

Информатика | 10 - 11 классы

Дана строка.

Среди символов встречаются цифры.

Написать программу, вычисляющую сумму всех цифр.

Ответить на вопрос
Ответы (1)
569фы 17 окт. 2020 г., 22:24:57

Var digits : set of '0'.

'9' ; s : string ; i, p, d, err : integer ;

begin digits : = ['0'.

'9'] ; Write('Введите строку : ') ; Readln(s) ; p : = 0 ; for i : = 1 to Length(s) do if (s[i] in digits) then begin Val(s[i], d, err) ; p : = p + d end ; Writeln('Сумма цифр равна ', p)

end.

Тестовое решение :

Введите строку : Сегодня 17 декабря 2014г.

Находим сумму 7 цифр их этой строки.

Сумма цифр равна 22.

Valelelentinaa 31 мая 2020 г., 23:32:48 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти : сумму его цифр.

Написать программу на Pascal'е.

Пиксик2 11 дек. 2020 г., 22:37:18 | 10 - 11 классы

Дана строка символов Сколько раз среди данных символов встречаться цифра?

Дана строка символов Сколько раз среди данных символов встречаться цифра?

Паскаль.

Подскажите.

Ilonabolataeva 27 дек. 2020 г., 21:57:08 | 10 - 11 классы

Дана строка символов, состоящая только из цифр?

Дана строка символов, состоящая только из цифр.

Определить, сколько раз среди них встречается цифра 5.

DreamSweets555 2 мар. 2020 г., 17:35:42 | 5 - 9 классы

Нужна помощь?

Нужна помощь!

Нужно написать программу в Pascal ABC вычисляющую сумму цифр двухзначного числа.

8 класс.

Dimamakarenkorus 23 июл. 2020 г., 01:13:36 | 10 - 11 классы

Напишите программу, которая подсчитывает сумму всех цифр в данной строке?

Напишите программу, которая подсчитывает сумму всех цифр в данной строке.

Например, в строке "Sochi - 2014" сумма цифр равна 7.

Формат входных данных

Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.

Формат результата

Одно число — сумма цифр в строке.

Для Python.

Ramazanovrifat 23 июн. 2020 г., 12:39:58 | 5 - 9 классы

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа?

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа.

(Pascal).

Zm755 29 июн. 2020 г., 21:10:09 | 5 - 9 классы

Дана строка?

Дана строка.

Среди символов строки встречаются цифры.

Написать программу, вычисляющую сумму всех цифр строки.

Lerkabelka2004 2 авг. 2020 г., 19:24:27 | 1 - 4 классы

Известно количество символов в каждой строке, количество строк на странице?

Известно количество символов в каждой строке, количество строк на странице.

Написать программу, считывающую эти значения с клавиатуры и вычисляющую число символов на странице.

ВЫПУСКНИК2014 10 янв. 2020 г., 18:59:00 | 10 - 11 классы

ПРОГРАММА НА PASCAL?

ПРОГРАММА НА PASCAL!

Распечатать введенную строку, удалив из нее символы, не являющиеся буквами и цифрами, и ЗАМЕНИВ КАЖДУЮ ЦИФРУ НА " * * ".

Kristi1617 20 июл. 2020 г., 11:55:34 | 5 - 9 классы

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL.

Вы открыли страницу вопроса Дана строка?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.