Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Определить сумму его цифр, больших 5.

Ответить на вопрос
Ответы (1)
Lizapeanut 19 дек. 2020 г., 23:26:37

Программа слаживает все цифры натурального числа, введённого пользователем, и выполняет из них сумму :

var r : real ; s : string ; q : integer ; sum : real ; i : integer ;

begin Write(' Введите натуральное число : ') ; Readln(r) ; s : = FloatToStr(r) ; q : = length(s) ; for i : = 1 to q do begin r : = StrToFloat(s[i]) ; if r > ; 5 then sum : = sum + r ; end ; writeln(' Сумма всех чисел, превышающих 5 = ', sum, '.

') ; end.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

28071997 14 февр. 2020 г., 08:49:37 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Верно ли, что сумма его цифр больше 10?

Paskal.

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Polyagrig 9 февр. 2020 г., 09:02:45 | 5 - 9 классы

Дано четырехзначное натуральное число?

Дано четырехзначное натуральное число.

Определить является ли сумма первой и последней цифр кратной 3 Паскаль.

Bentlii 21 нояб. 2020 г., 04:16:15 | 5 - 9 классы

Даны два натуральных числа?

Даны два натуральных числа.

Выяснить в каком из них сумма цифр больше.

(Определить функцию для расчета суммы цифр натурального числа).

Nastenkastasevi 22 нояб. 2020 г., 03:21:15 | 10 - 11 классы

Дано натуральное число определить его максимальную цифру?

Дано натуральное число определить его максимальную цифру.

Vipaybashev1 16 окт. 2020 г., 18:36:21 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Определить : a) Количество цифр в этом числе ; б)Сумму его цифр ; в)Первую цифру числа n ;

121redto 31 дек. 2020 г., 03:21:42 | 5 - 9 классы

Дано натуральному число?

Дано натуральному число.

Верно ли, что сумма его цифр не меньше 10?

На этой странице сайта размещен вопрос Дано натуральное число? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.